Home Forums ACF PRO Post Objects no longer showing posts


Post Objects no longer showing posts

  • I built a set of custom fields and one of them was a Post Object field. It used to populate with a list of all the posts but now it shows nothing. I don’t know when this broke but it did originally work.

    Kermit Woodall

  • Have you tried disabling other plugins on the site and/or switching to a default theme? There may be some type of conflict with another plugin or the theme.

  • I disabled everything but ACF and CPT UI (Custom Post Type UI) and changed to the Twentyfifteen theme and it still doesn’t work.

  • CPT UI, I use it too. There have been problems with that plugin during updates. You may need to re-save your permalink structure. You may also need to go into the CPT UI admin and update your post types and taxonomies.

  • Here is one of the issues that discusses it over on the github repo, there may be others.

  • Ok. I just did both of those and it still doesn’t work. I then applied your new update and it still doesn’t work after that. I also deactivated CPT UI then reactivated it and it still doesn’t work.

    My next test was to get the code for the CPT UI post types and taxonomies and put it into functions.php and turn off CPT UI altogether – and it still doesn’t work.

  • Have you looked at the ACF fields to make sure they’re still pointing to the right post types? That’s just about the last thing I can think of. I know that post objects are working fine on my test sites.

  • Yes. I pretty much always checked that. Would you like to look at the site?

  • I solved it myself. I deleted the ACF for that post object. Updated the field group. Added it back and it worked again.

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Post Objects no longer showing posts’ is closed to new replies.