Support

Account

Home Forums ACF PRO "Post Object" not saving

Solved

"Post Object" not saving

  • Hi! I’m loving ACF PRO. One issue I’m having is with saving post object fields.
    I have a CPT “contact”.
    On the “contact” CPT, I have added a Post Object field called “contact_worker” with the following parameters:
    – required – no
    – filter by post type – set as “contact”
    – filter by taxonomy – set as “worker”
    – allow null – yes
    – select multiple values – yes
    – return format – post ID (I’ve also tried post object but it didn’t work either)
    – conditional logic – no

    I intend to use this in a frontend form, but right now I’m testing in the WordPress admin. I create a new “contact” and select a worker, then save. All the fields save, but not the “contact_worker” (Post Object field type).

    Any ideas on troubleshooting my issue.

  • Hi @jlamb

    That’s weird. Could you please make sure that no other field has the same name on the page?

    Also, could you please try to reproduce the issue on one of the WordPress’ stock themes (like Twenty Fifteen) with other plugins deactivated? If it disappears, then you can activate the theme and plugins one by one to see which one causes the issue.

    If the issue persists, could you please submit a new ticket here: https://support.advancedcustomfields.com/new-ticket? Please explain the issue again and provide the temporary credentials to your site in the ticket.

    Thanks ๐Ÿ™‚

  • It looks like the CPT needs “has_archive” set to true in order to work correctly. Problem solved

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.