Home Forums Backend Issues (wp-admin) Page updates not saving


Page updates not saving

  • Hey Eliot,

    I was recently getting the wp is not defined in input.min.js error on my live site.

    I have since updated the ACF plugin to the latest version from github, which appears to have fixed that issue (all the JS is now running error free).

    Unfortunately, my page is no longer saving changes when I click update. The page sends the data, and refreshes, but any updates I have just made are not saved.

    This does not appear to be happening on every page – just the home page, which contains a large number of fields.

    I’m running
    Wordpress: V3.8.1
    ACF: V4.3.4 (github version)
    ACF Repeater: V1.1.1

    Any ideas?


  • Hi @barneyfoxuk

    How many fields are we talking about?
    Have you tried reducing the amount of fields? This may reveal that the problem is related to a specific amount of fields.


  • I have this issue as well. I just created a new field group with one WYSIWYG field. I added the group to my blog page, but when I type text in the ACF WYSIWYG editor and update the page, the editor is blank after the page refreshes (so my text is not saved).

    I created a new page to test and for some reason was able to successfully save the custom field on that page. Somehow it seems to be specific to my Blog page, as if it has gotten corrupted or something? I don’t see any JS errors.

  • If I remember well, try to reinstall ACF plugin… I think it did the trick for me.

  • I am having the same issue. I set up a test ACF with only 1 text field named “test” to confirm it was not an issue of too many fields or too long field names … no value saved

  • I’m experiencing the same issue, but only for the home page. All other pages the fields work fine. I downgraded to another version and it still doesn’t work, disabled all other plugins too without it working. This needs to be fixed ASAP! Or does anyone else have the similar issue. One of my sites are using multiple tabs/fields.

  • This reply has been marked as private.
  • I found a work around for this issue, by using the Add-On “options”. This solves the issue for things not saving on the index pages.

  • I am getting same issue, when I try to create new blogs using ACF, page is not getting saved, when I click on update.There is no issue with existing blogs.

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Page updates not saving’ is closed to new replies.