Support

Account

Home Forums Add-ons Options Page Options ACF page changing multiple ACF pages

Solved

Options ACF page changing multiple ACF pages

  • Hey all.

    Breaking my head against a wall. I have a client who want to have contact information for herself and her publisher. As I needed the information to go on multiple pages, I thought Options would be the best way to go.

    I created multiple Options pages in the functions.php

    acf_add_options_sub_page("Business Details");
    acf_add_options_sub_page("Publisher Details");
    acf_add_options_sub_page("Header");
    acf_add_options_sub_page("Footer");
    acf_add_options_sub_page("Placeholders");

    I then create an ACF with 11 fields to collect address, phone, email web etc and attach it to a the two pages. I entered information on the publisher page and when I went to enter the information into the business options page, it had the information from the publisher page. I deleted it and it deleted it from both. Thinking then that maybe I needed to create seperate ACF’s for each, I exported the Publisher ACF and then opened it to update it so it would import as Business. When I imported it, all went well, assigned it to the buisness page but then the duplication started again.

    Thinking I had possibly assigned the same field names accidentally, I went into the wp meta and wp posts tables via phpMyAdmin and deleted all reference to the two mentioned ACF’s.

    In short, it is still doing it no matter what I do. Am loosing my mind.

    any ideas would be muchly appreciated.

    Cheers
    Muz

  • Okay.
    Not sure how it goes but I have semi fixed it.
    From what it looks like, you cannot have fileds named the same thing even if they are under different ACF’s (when used in options). I put a prefix of publisher_ on the publisher table and a prefix of business_on the busiess ACF. That sort of fixed it. Some data disappeared, Elvis was spotted at 7/11.

    Onward and upward.
    Muz

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.