Support

Account

Home Forums Add-ons Options Page Option page is not showing in admin menu

Solved

Option page is not showing in admin menu

  • Hi there,

    I want to create a new option page calles Services. I have add the code below to my functions.php but nothing is showing in the sidebar menu. I have deactivated all the plugin and check it but still nothing shows up. FYI, I am using Divi theme and build website in Localhost. Any idea? Please help me. Thank you. This is the code I have added to my functions.php:

    add_action(‘acf/init’, ‘my_acf_op_init’);
    function my_acf_op_init() {

    // Check function exists.
    if( function_exists(‘acf_add_options_page’) ) {

    // Register options page.
    $option_page = acf_add_options_page(array(
    ‘page_title’ => __(‘Services’),
    ‘menu_title’ => __(‘Services’),
    ‘menu_slug’ => ‘services’,
    ‘capability’ => ‘edit_posts’,
    ‘icon_url’ => ‘dashicons-book-alt’,
    ‘redirect’ => false,
    ‘position’ => ’20’,
    ‘updated_message’ => __(“The services has been updated”, ‘acf’),
    ));
    }
    }

  • I’ve tried your code and it’s working as expected.

    How many other things are appearing in the admin menu between pages and comments? If you have too many and there is a conflict items with the same menu position will not be shown. Pages is a 20, comments is at 25, this means if you have more than 4 menu items additional menu items at position 20, then some may not be shown.

    Try setting the menu position to something like ‘20.111111’

  • @hube2 Hi John, I only installed Testimonials and ACF plugin in my wordpress website. Therefore, my admin dashboard menu is very simple. Between the Page and Comments menu is Testimonials menu. I have changed “20” to “20.11111”. Still, it doesn’t work. Oh, my ACF plugin is the free version. Is it the problem?

  • Yes, options pages only work in the Pro version or with the options page add on.

  • @hube2 I got it. Thank you for helping me, John!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.