Home Forums Bug Reports Option Fields not saving within Flexible Content


Option Fields not saving within Flexible Content

  • Hi @elliot,

    Just encountered a bug when saving values within a 2x repeaters and flexible content field. It says it saves fine, and appears to have saved. But then I left the options page (after saving), and then re-entered, and it didn’t actually save it.

    Using Options, Flexible Content and Repeater plugins. Have tried disabling other plugins, just having ACF by itself – but didn’t change anything.

    I’ve also tried flushing out post revisions, still no luck.

    I’ve tried changing the PHP settings, including all of the below:

    max_input_vars = 3000;
    max_input_nesting_level = 128;
    max_input_time = 300;
    max_execution_time = 300;
    post_max_size = 32M;
    memory_limit = 300M;

    But didn’t fix it unfortunately.

    I will attach a private login example, so you can check it out.

    Does anybody know a fix for this?

    Kind Regards,

  • This reply has been marked as private.
  • Hi @startupguys

    I have a feeling that this issue is related to a character length of the value you are trying to save.

    The wp_options table has a character limit of 64 on the options_name column. This means that WP can’t save any data that exceeds this limit. Your nested repeater field is most likely causing the field_name to become too long.

    For extra reading, you can read about how the repeater field saves it’s data here:

    Your options are to either:
    1. Increase the ‘Length’ for the option_name column
    2. Change your field names to be shorter


  • Hi @elliot,

    Perfect, that fixed it for us 🙂

    Thanks for your excellent support once again!


  • Is there any way that this can be fixed via the core? I’m thinking either a validation check or an automatic change to the db that increases the character limit on the options_name field.

    The validation would go check the limit and compare it with the options_name it’s trying to save. If it fails, the user would get some kind of notice that doesn’t allow them to save this field or at least warns them that this field won’t work until they choose a shorter name. It just seems like a poor user experience to have it look like everything’s fine, when in reality, it won’t work at all.

    Thanks again for a great plugin!!!

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Option Fields not saving within Flexible Content’ is closed to new replies.