Support

Account

Home Forums Backend Issues (wp-admin) On WP 5.0 with Classic Editor 1.0 Installed, cannot edit field groups

Solved

On WP 5.0 with Classic Editor 1.0 Installed, cannot edit field groups

  • WP 5.0 freshly installed, with default Gutenberg (ugh)
    Classic Editor 1.0 installed
    ACF PRO 5.7.7 installed

    All editing works ok on Pages and Posts.

    When clicking Edit on a field group (from http://mysite.org/wp-admin/edit.php?post_type=acf-field-group), you get a url like this:

    http://mysite.org/wp-admin/post.php?post=23&action=edit&classic-editor

    However the screen is white and nothing loads. This is on a brand new install of WP.

    Please advise, thank you. I’m sure you’ll be getting lots of these because Gutenberg is terrible, so hopefully this will help others.

  • Can confirm. Just updated a local dev site I’m working on to 5.0 with Classic Editor installed and can no longer edit the field groups.

  • Confirmed as well… Can’t add/edit Groups. Using Classic Editor as well as disabling Gutenberg with…

    // Disable Gutenberg
    
    if (version_compare($GLOBALS['wp_version'], '5.0-beta', '>')) {
    	
    	// WP > 5 beta
    	add_filter('use_block_editor_for_post_type', '__return_false', 100);
    	
    } else {
    	
    	// WP < 5 beta
    	add_filter('gutenberg_can_edit_post_type', '__return_false');
    	
    }

    *** as well as other Gutenberg disabled snippets

    • nblight

    • December 7, 2018 at 8:33 am

    I was having the same problem, then discovered that the Classic Editor plugin adds some new setting options. After enabling the plugin, go to Settings > Writing and then set “Default editor for all users” to “Classic Editor” and “Allow users to switch editors” to “No”. That seems to have fixed it, at least on my test site.

  • Thank you nblight. That fixed it for me as well. I had just checked Classic Editor yesterday settings-wise, but didn’t check it after it updated today.

  • @nblight — replicated that and it works as well. Thanks!

    • Elliot

    • December 7, 2018 at 10:27 am

    Hi all,

    Thanks for the bug report. I am currently in communication with the Classic Editor developers about this issue here: https://wordpress.org/support/topic/classic-editor-is-blank-in-wordpress-5-0/#post-10955802

  • @nblight that solved my problem, thank you.

    What an utter fiasco this Gutenberg rollout has been. Various settings, plugins, and lines of code needed to simply maintain the user experience and UI we’ve built for clients.

  • @elliot on that note are you planning on supporting ClassicPress when it comes out?

    • Elliot

    • December 7, 2018 at 1:50 pm

    This issue looks to be solved in Classic Editor 1.1: https://wordpress.org/support/topic/acf-field-groups-wsod-when-classic-editor-is-active/#post-10956315

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.