Support

Account

Home Forums Backend Issues (wp-admin) On Image Upload Receiving HTTP Error

Solving

On Image Upload Receiving HTTP Error

  • Hello,

    I seem to be having an intermittent issue where when I try to upload an image it gets stuck in the upload process and eventually gives me a “HTTP error.”

    Versions: WordPress: 3.6, ACF: 4.2.2, Flexible Content: 1.0.2, Repeater: 1.0.1

    If I open up the console I see the following:

    POST /wp-admin/async-upload.php 404 Not Found

    TypeError: A is null
    …ape(encodeURIComponent(Y))+U});H=l.mimeTypes[x.name.replace(/^.+\.([^.]+)/,”$1″)…

    Any ideas on what I can do to fix this? It doesn’t happen on every upload and if I check the media library after the error, it appears the the image was uploaded.

    Thanks in advance.

  • Hi @graphix

    I’m not 100% what the solution is here, but it is clear that some debugging will be need to find the culprit.

    I would attempt removing all other plugins / theme to rule out a conflict with another plugin.

    I would also try with another user account to rule out user role issues

    Also, try turning DEBUG MODE on / off to see errors / fix PHP isues which could be breaking the async-upload.php file

    Good luck mate

    Cheers
    E

  • I had the same error. I noticed that the user logged in uploading an image needs to be a Author or Admin for it to work. I was getting the HTTP Error when the user level was just a Subscriber or Contributor.

  • @idreamincode

    That’s interesting, however mine is even occurring with my default admin user.

    @elliot

    This is occurring on a fresh install of WordPress, with no plugins installed yet (other than the ACF plugins of course).

    I tried doing it with another admin user and that didn’t work either.

    I turned of debug mode and fixed two depreciated functions I was using, but that didn’t seem to be related.

    I checked my HTTP Error log on my server and found the following error:

    [Wed Sep 18 06:19:13 2013] [error] [client] Premature end of
    script headers: async-upload.php, referer:
    /wp-admin/post.php?post=12&action=edit

    But that doesn’t help us much, so as per my host’s recommendation, I’ve enabled a PHP error log and am now trying to reproduce the error (which doesn’t seem to want to reproduce at the moment, of course) so maybe I can get some more details on what is going on.

    I did notice two errors in my new PHP log which related to ACF, but I can’t confirm if they are related to my HTTP Upload Error yet:

    [18-Sep-2013 20:55:55 UTC] PHP Fatal error: Maximum execution time of 300 seconds exceeded in /wp-content/plugins/advanced-custom-fields/acf.php on line 311

    and

    [18-Sep-2013 20:16:16 UTC] PHP Fatal error: Maximum execution time of 300 seconds exceeded in /wp-content/plugins/advanced-custom-fields/acf.php on line 283

  • Hi @graphix

    Thanks for the detail, however, I am at a loss with any idea of why your upload is timing out.

    Is the upload taking place from the font or back end of the website?
    Do you ever have this issue with any other upload form in WP?

  • Thanks for your reply @elliot

    It is happening in the backend, the file upload field is within a repeater, which is part of a flexible content field.

    I have not got any WordPress upload issues with the other forms like the media upload button on a page.

    Very strange. If the error persists, I’ll get the error from my PHP log and report it here.

    I normally have no issues uploading on this server with ACF (I use it all the time). The only thing new that I’ve done is update to the newest version.

  • I have http error with ACF gallery upload

  • Hey @elliot I’ve been going round in circles.

    I’m getting the exact same errors thrown as @graphix.

    I can’t seem to trace the issue at all.

    The annoying thing is it’s only happening on my client’s machine.

    And not mine.

    Hmm.

  • Hi there,

    I am having the same problem with frontend acf-form which I want to use for frontend publishing.

    Hope a solution can be found soon.

  • Suddenly having the same error two. Same theme as I’ve used previously with no issues, clean install, same server…

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘On Image Upload Receiving HTTP Error’ is closed to new replies.