Home Forums General Issues No required alert in user profile


No required alert in user profile

  • Hi,

    I created an ACF ‘Text’ field to ‘User’.
    And made this field as ‘Required Yes’.

    However, I can update and save user profiles even if this ‘Text’ field empty without any alerts.

    Is this my mistake or some bug?

  • I just tested this and it’s working like it’s supposed to. You’ve probably got some type of JS error, possibly caused by a plugin conflict or something.

  • Hi John,

    Thank you for your answer.

    I checked JS error again, but could not find any error in blowbrowsers.

    Win8.1 IE11
    Win8.1 Chrome 63.0.3239.108
    Win10 Edge 41.16299.15.0
    Mac Safari 11.0.2

    And my WordPress is clean installed site at few days ago.
    I just installed WordPress and no customize any PHP and no install extra plgins without ACF.
    My WordPress enveronment is as below.

    *WordPress v4.9.1 (Japanese version -> reinstall US version)

    Advanced Custom Fields : Active
    Akismet Anti-Spam : No active
    Hello Dolly : No active
    WP Multibyte Patch : No active (WordPress Japanese included plugin)

    If you can test in new WordPress site pelase test it again.

    Thank you very much.

  • My test was on a site that is the latest version of WP with the latest default theme and only ACF active. Everything is working as expected. I don’t know what you mean by

    *WordPress v4.9.1 (Japanese version -> reinstall US version)

    If the validation is not working then you have something that is interfering with the operation of the JavaScript and AJAX request associated with it, or for some reason ACF is detecting that the field is not empty. I would try deleting the field and creating a new one and trying it again. Beyond that I can’t give you much advice. You could try submitting a new support ticket and see if they can help you

  • Hi John,

    Thank you for your answer.

    *WordPress v4.9.1 (Japanese version -> reinstall US version)

    This means is what I installed Japanese version first, and update US version.

    And I tried deleting the field and recreated new one, but still no alert even if empty.(text field, checkbox field)

    I gave up this problem.
    Thank you very much.

  • Are you having the same issue anywhere else? Do you get the same result for a required field on on a post?

  • Hi John,

    Thank you for your answer at New Year!

    I tested as below.

    [Show this field group if]
    *[Page] [is equal] [mypage] : Works fine required fields.
    *[Post Type] [is equal] [post] : Works fine required fields.
    *[User] [is equal] [All] : No alert required fields even if empty.
    (I tested both exist user update and add new user.)

    Only ‘User’ doesn’t work fine…

    Thank you very much!

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘No required alert in user profile’ is closed to new replies.