Support

Account

Home Forums Backend Issues (wp-admin) New Issue – Media Library not loading images in Media Library and via Add Media

Solving

New Issue – Media Library not loading images in Media Library and via Add Media

  • Hi there,

    Just added this topic again because I have not heard back from the support about this problem at all.

    I am researching a solution for an issue with one of my clients websites for quite some time (actually almost a year now) and I could not find a solution up to this point.

    Today I finally had the time and we mirrored the live site to a test server. So that we have a 1on1 copy of the live site to test things more deeply

    Issue:
    The site does not show anything in media library grid – not when I open the media library directly nor when I go to a page/post and click “Add Media”.

    First I thought it has to do with another plugin or the theme.

    But now on the testserver I deactivated all the plugins and then reactivated one by one and it seems the problem is Advanced Custom Fields.

    I deactivated all other plugins and only had ACF active and then tested and the issue was there – when I deactivated ACF the media library loaded fine.
    Then I reactivated the other plugins and left ACF deactivated and the media library loaded fine.

    So it is definitely an ACF issue.

    I have also recorded a video to show you the problem through live video. This is the link to the screencast I recorded:

    https://www.dropbox.com/s/eglurfmwc0qcyk9/ACF-Issue-Media-Library.mp4?dl=0

    The site is build heavily on advanced custom fields so there is no way I can just deactivate it on the live site and then let the site run without ACF.
    But I guess since it is an issue with ACF I guess there should or will be soon (hopefully) be a fix to that.

    The live site is running WordPress 3.9.2 and it is not working there and the mirrored test site was just activated to 4.1.1 to test if it has something to do with the WP core but the same issues there. The video shows you the test server site that runs 4.1.1.

    Both sites run
    ACF 4.4.0
    ACF Flexible Content Field 1.1.1
    ACF Options Page 1.2.0
    ACF Repeater Field 1.1.1

    Hope that helps.

    If you need to get access to the test server site – please let me know and I can add another admin user to the test site.

    I need you help in order to fix that because the admins of the live site are not happy with having to reupload each image and to be fair it does not help our server space neither.

    Looking forward to your answer.

    Best regards,
    Sammy262

  • Same issue here:
    WP version 4.2.2–es_ES
    Advanced Custom Fields Pro (Version 5.2.7)

  • Hi @sammy262 and @abuky

    Let’s get to the bottom of this then!
    @sammy262 have you also tried just deactivating the add ons you’re using but keeping ACF core? Also, can you check the console in chrome (or firebug) if there’s any JS errors occurring when trying to access the library.

    @abuky same for you, can you check if you’re getting any JS errors?

    Also, @sammy262 is your test environment exactly the same as the live one?

  • My problem got fixed when I updated the core to ACF 5 and then deactivated the old plugins.
    There must have been something wrong with ACF 3or 4.

  • And if I remember correctly there was a JS error – it looped through an error infinitely – but it had nothing to do with smaller thumbnails and this kind of stuff what you find in some other forums – I tried everything for 5 months.

  • Hello Everyone,
    Thanks for the quick response.
    I did try to deactivate all other plugins and also many other things I read on the forums without success.
    I don’t get any error, neither on the JS console or on the server side (by the way the server is running PHP Version 5.5.6).
    One wired thing is that the site was working fine but suddenly this error started to happen. As far as I know there where no changes on the server or updates that may be related.
    Last week I tried, among other things, to reinstall the WP form the WP panel and solve the problem for some time until it begun to fail again. I tried to reinstall the WP again but it didn’t solved the problem on the following attempts.
    This week I reinstalled everything from a backup and it worked fine at the beginning until It begun to fail again. No update was run in the meantime. I’ve been trying to isolate the problem or figure out what was that trigger it without any success.
    I have to say that I use ACF on a number of other sites and this is the only one with this issue. I suspect that may be related with the ACF gallery, but I have no solid argument. I’m really kind of lost here.

  • After reinstalling everything again I discovered something. When I deactivate another plugin (WordPress Firewall 2) the media library works perfect again.
    I apologize in advance if the issue is coming from this other plugin. I’m sure I deactivated before (on previous re-installs) and it didn’t solved the problem. Also as I mentioned before, on previous reinstalls it worked OK until this error seems to come from nowhere, so I’ll let this plugin down for a while and cross fingers that the error is gone for good.
    I’m sorry I can’t be more specific right now.

  • @sammy262 That’s great to hear! I’ve seen something like this issue from other people too with ACF4 so it might be an issue there either with core or an addon.

    @abuky Ah I see.. Well reading what you’ve experienced and checking the WordPress firewall 2 plugin I would also guess this plugin is your issue.
    Just the fact that it hasn’t been updated for over 2 years makes me cringe. It’s very possible it’s causing something to throw an error or possibly block server requests for the media since these are done with AJAX.

    Keep that plugin disabled and if you’re not already using another security plugin I would suggest taking a look at ithemes security, Wordfence or All in one security. I don’t think you need that old plugin i you’ve got one of these well used and frequently updated plugins.

  • This reply has been marked as private.
  • I am also having this issue (images won’t load from /wp-admin/upload.php in Grid view but do load in List View)–I switched to the Twenty Nineteen theme, deactivated all plugins (fixing the issue) and then activated only ACF Pro Version 5.8.2 and the problem returned. No errors in the js console or in server logs, just won’t load images and shows the wheel spinning indefinitely. I think I’ve used the most recent version of ACF Pro on other installs without a problem, so I can’t figure out what could be different. Any ideas?

    WordPress 5.2.2 with all other plugins deactivated, with up-to-date Twenty Nineteen theme.

  • Update to my last message–I was able to resolve the issue by regenerating all the thumbnails. Perhaps there was corrupt metadata that only ACF was trying to read or something.

  • I have an issue with not loading Media Popup from admin to add/update any images.
    Look at the attached image.

    ACF media error

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.