Support

Account

Home Forums ACF PRO New custom fields not saving data

Solving

New custom fields not saving data

  • Some basics:
    ACF Pro version 5.5.13
    WP version 4.7.4

    I’ve recently had to revisit a site that has been working perfectly for nearly a year. It is made up of two custom post types, each populated by a number of field groups.

    I now have to add a new field group to one of the custom post types, and I’m running into the issue of data not being saved to the database.

    The field group added is a repeater, with two sub fields, limited to six instances.

    Things I’ve tried:
    Disabled all other plugins, and switched to twentysixteen – no data saving.

    Upped the max_input_vars value in the php.ini file. No data saving.

    I don’t believe the issue is the max field name length. The field group’s name is “repairs_estimates”. The subfields are “repair_needed” and “repair_estimate.”

    The field names are all unique.

    I’ve tried placing the field group higher in the order of field groups that are assigned to the custom post type in question – doesn’t appear to make any difference.

    Additionally, if I try to add the repeater field to another previously existing field group – it wont save data. If I try to add a more basic field – text for example – it won’t save the data.

    I am able to edit data that is already saved to a post. And I’m able to create new custom posts – all fields that were being used prior to this issue are still working fine. I just can’t seem to add any additional fields.

  • Oh.

    For what it’s worth, the two custom post types are defined in my functions.php file. I’ve added a decent amount of other code to the functions.php file, but stripping it back down to just defining the custom post types doesn’t do the trick either.

    Basically – everything done prior to a couple days ago has worked fine, and is still working fine. I’m just unable to add any additional fields.

  • Hello, were you able to get resolution to your issue? I have a very similar problem, where I am unable to edit the current data that’s already saved to a post (the already saved data appears on the webpage correctly however). When I do another update on the page (to another section), I see entries being made to the database in wp_postmeta. However, I don’t have an interface to edit my current repeater entries.

  • Yeah, I am having this issue too with a client website. Been working fine for years but now a price field is not updating.

    On saving the page the price field reverts back to what it was and not the new value.

    Have you been able to replicate this bug? I have a website I can give you access too if needed.

  • This reply has been marked as private.
  • I am having a similar issue. I imported ACF fields into a new site, with content from three old sites. The fields are completely uneditable though, and I can’t create new fields in any way either.

    I upped max_input_vars, and checked all settings, but nothing seems to help. I also removed the plugin and re-added. Any ideas would be helpful.

  • My issue could be similar, it was working on my local but not after it had been moved by the looks of it.

    I have not tried editing the main ones but will give it a go. If I find a fix I will report back because the owner of this plugin doesn’t seem bothered to chime in on this.

  • Ok so I solved mine. I checked and there was another sync which had 2 for each fieldset for some reason. I deleted the duplicates and it’s all working fine now. So check your syncs

  • My issue is tied to Jetpack. If I leave the theme alone but deactivate Jetpack, I can edit the ACF fields and nothing bad happens. But if I edit the fields while Jetpack is active, the fields vanish and I can’t create new ones either.

    • nl

    • August 21, 2017 at 6:48 pm

    My issue is with JETPACK too – I deactivated JEtpack, the ACF fields start working again.

  • The only time I’ve seen ACF field groups that could not be edited is when I’m using acf-json and the acf-json folder is not writable for some reason. The groups are updated in the DB but not in the files. Do you have the acf-json folder set up for your theme and can jetpack somehow be preventing the json files from being updated?

  • Same deal with me – If Jetpack is enabled I can’t work with ACF fields in wp-admin. If I try, my custom fields appear to be wiped out. As soon as I deactivate Jetpack it all works fine again (although I have to recreate any fields I previously tried to edit while Jetpack was active).

  • I did some searching, not sure if anyone here has see these

    https://wordpress.org/support/topic/conflict-with-advanced-custom-fieldsacf/

    https://github.com/Automattic/jetpack/issues/7565

    • kychd

    • September 25, 2018 at 8:55 am

    I had the same problem. The reason was that the field did not have a name. After assigning a name to the field, everything worked

    • Spylon

    • January 6, 2019 at 6:35 am

    I was facing a similar problem. This might not fix for your problem, but it could help others that find this topic due to it’s title.

    In order to get my prefered lay-out in the WP-admin, I put my fields in a group. I didn’t name the group since I used it entirely for aesthetic purposes. My fields didn’t save either, even though they were all named and labeled. Simply giving the group a name fixed the issue.

    ACF Pro version 5.7.2
    WP version 4.9.9

  • Not sure if this issue has been resolved. I am having a similar issue. I have created a custom post and added custom fields using ACF. When logged in as an admin, everything works perfectly but when one of my users logs in (Author or Editor roles), the custom fields did not save data. Looks fine on the page after Publish is clicked, but a refresh and the fields are empty. Title and featured image stay, but no custom fields. As with other suggestions I installed classic editor plugin and that has solved the problem for me. A shame not to be able to use Gutenberg but we will live with it.

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.