Home Forums Add-ons Repeater Field Nested Repeater Stopped Saving


Nested Repeater Stopped Saving

  • The parent repeater will not go past the 32. I have tried increasing the PHP memory and timeouts. Still won’t save.

    I saw a “solution” in another thread that said to put this in the .htaccess file:
    php_value max_input_vars 3000

    I am not well-versed in correct syntax for the .htaccess file. Doe this need to be wrapped in something? Some way to trigger it? I just plopped it in there. It doesn’t work. Not sure whate else I can try.

  • Anybody? Thoughts? I am hesitant to build this a different way for fear of it crapping out at 32 entries.

  • The only possibility that I know of is max_input_vars, but it could be or suhosin.request.max_vars also needs to be set. Try this plugin

  • That plugin hasn’t been updated in 3 years. Thanks though. I increased the vars in the PHP, but it still is stuck. Increased time limits and just about everything. And, we restarted Apache. No dice. First time since I have been using ACF that this has happened. Running out of ideas. What else would cause the system to stop saving content fields in ACF?

  • While the plugin has not been updated for 3 years it still works and does not cause any issues. I run it while I’m doing dev work on complex field groups.

    Where exactly did you change the value. These values can only be changed in php.ini or in .htaccess if your host allows it and it’s not a value you can alter with ini_set()

  • I installed it. It says the “Field limit: 1000” next to “Deactivate” in the list of plugins. I do not see a way to increase that number via the plugin.

    So this plugin is a warning? Meaning it does not change the max number but lets you know “This isn’t going to work” before submitting and I will need to change that limit elsewhere?

    When I attempt to add another item to my nested repeater with this plugin active I get this warning:

    “This form has too many fields (1017) for the server to accept (max 1000). Data maybe lost if you submit. Are you sure you want to go ahead?”

    I have not clicked OK.

  • If you click ok then you’ll loose data you entered. You need to contact your host and find out how to increase the limit if you don’t already have access to it.

    With my host I can do this in my .htaccess file, but not all hosts work the same way, so I can’t really tell you what will work in your case.

  • So yesterday, I added the max_input_vars to my .htaccess file. No change. I then contacted my host about adding it to my php.ini file. Which is only accessible via SSH. Something I don’t work in. After much hand holding from my host’s tech support, I was able, through Mac Terminal to get into the php.ini file and change the commented out max_input_vars to uncommented and changed the 1000 to 5000. After all that, the plugin still says the max vars is 1000 and my ACF repeater will not save. Not sure what else to do. Not sure if rebuilding my ACF form in a different way would make a difference. For instance, I could make the parent repeater, not a repeater and instead make each of those individual repeaters. So that their is no nesting. But they are still all on the same page. It might make fewer vars but I think I would still hit 1000 pretty quickly.

  • PROBLEM SOLVED! It was MY code. I missed the “=”. So I hade “max_input_vars 5000” when it should have been “max_input_vars = 5000”

    Plugin is now showing Field limit: 5000 and I a can save the nested repeater.

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Nested Repeater Stopped Saving’ is closed to new replies.