Home Forums ACF PRO Nested repeater fields not working in 5.1.1


Nested repeater fields not working in 5.1.1

  • Hi,

    I just updated ACF to 5.1.1 and nested repeater fields are no longer being displayed. Everything on the backend for the field looks fine.


  • We’ve run into the same issue where repeater fields and Flexible Content Fields no longer work with 5.1.1. They work fine if you stay on 5.1.0 though so we’re keeping all our sites there in the meantime.

  • Same thing here. To elaborate on the bug, in my case the problem occurs when flexible content field names are duplicated.


    Flexible Content Layout #1
    Name: type1
    Fields: subfield1

    Flexible Content Layout #2
    Name: type2
    Fields: subfield1, subfield2, subfield3

    get_sub_field(‘subfield1’) will only work for rows of layout ‘type1’. For a row of layout ‘type2’ fields with unique names will display (‘subfield2’, ‘subfield3’), but the field with a duplicate name will return empty (‘subfield1’).

    Downgrading to 5.1.0 fixed the problem.

  • Same here!
    After updating to ACF Pro 5.1.1, have_rows('repeater_field_name') returns true even with no rows in the repeater/flexible content field. This is a serious bug…
    Had to roll back to 5.1.

  • Same here. I’ve opened a ticket and they said they have received more reports on the issue and are working on it.

  • Hello,

    Same for me, maybe it’s not due to 5.1.1…

    I have 3 ACF Forms 1 recent, 1 old and 1 very old… with repeater fields
    ## Repeater : list_price_visit_factory >>> Sub : description_price_visit_factory + price_visit_factory
    1/ The very old works again and give me values on back office. [field_53]
    2/ The old one works again but don’t load values on BO. [field_543bdcf31cbfd]
    3/ The recent doesn’t work anymore and the ACF groups after update for the repeater, SubFileds are deleted… [field_5164419a0f4dd]

    Cheers Old Fields 😉


  • Yea I am getting that field_RANDOMSTRING stuff too. Looks like it is returning the post name from the database. The really weird thing is this worked fine just 4 days ago. Not sure what changed as I had already installed version 5.1.1. At this point though since I just installed it I don’t have version 5.1.0 to rollback to. Does anyone have that available to share?

  • @chris.moen you could download it by yourself. go to your account and choose the tag icon right beside the download button of ACF Pro and you will be redirected to a page where older versions are available.

  • Same here. The strange thing in my case is that it’s only affecting in one repeater. I have two repeaters in different flexible content fields and only one of them stopped working.

    This was working fine before the update. Now, after rolling back to 5.0.9, this working fine again…

  • Update: Just released ACF PRO 5.1.2 – fixes have_rows() issues

    Please let me know if your issues are resolved after updating

  • Hey @Alexander Albrecht
    Did you try to create a new repeater field with some subfields for the last version of ACF ?
    I can’t… Subfields disappear…
    After update Group Fields.

  • I’m having kind of the same issue with the current version ( When moving nested repeaters or adding an item between, items get duplicated. We set up several repeaters that change their fields depending on the type of media you select. It’s a List of filed like this:
    When you select “PDF” you get the fields “Name” and “File”, when you select “Link” you get the fields “Name” and “Internal Page”, etc. You get the point.
    What seems to happen when you move an item in the list is that ACF does not erase the subfields correctly and this duplicates entries. These duplicate entries do not appear in the backend but in the frontend.
    I replaced ACF with version 5.0.9 and now it works fine.
    Anybody having the same issue? Is this issue known already?

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Nested repeater fields not working in 5.1.1’ is closed to new replies.