Support

Account

Home Forums Backend Issues (wp-admin) My ACF fields got into the right column on post editing page

Solving

My ACF fields got into the right column on post editing page

  • My ACF fields have somehow moved into the right column under Permalink, etc… How can I move them back into the main body under the Gutenburg blocks like normal?

  • Pretty sure that’s a Gutenberg problem and not an ACF problem. The block editor wants to put EVERYTHING in that tiny sidebar on the right.

    If you create an ACF block and assign the field group to the block, you will at least be able to fill out the fields within the block. If the fields are for a CPT, you can add that block to a block template for the CPT, so that it’s there automatically when you create a new CPT post.

    There may be a way to force the field metaboxes to show up below the edit screen, but I’m not aware of it.

    • misfist

    • December 24, 2020 at 6:55 am

    > If you create an ACF block and assign the field group to the block, you will at least be able to fill out the fields within the block. If the fields are for a CPT, you can add that block to a block template for the CPT, so that it’s there automatically when you create a new CPT post.

    The fields created by ACF blocks are not saved as custom fields, so they’re not post meta. Therefore, this is not necessarily a solution.

    A possible solution:
    I found changing the position to “High (after title)” ('position' => 'acf_after_title') put the fields back in the main area, below the block editor.

    • gabiton

    • January 8, 2021 at 2:09 am

    This used to work fine before. So its probably related to a WP update.
    However its not a “gutenberg issue” but seems like a conflict (or maybe wordpress removed something?) between gutenber and ACF
    Setting it to high didnt sort it for me.

    • Pema

    • January 8, 2021 at 3:16 am

    I just had the same issue. It was to do something with the ordering of WordPress meta boxes.

    I was recommended by the support team to create a second user account and test with that account. If you can view AFC fields normally in the editor window with the new user account, it is to do with the settings with the old account.

    It involves deleting some entries from database entries using phpMyAdmin interface. The recommended I to refer to this article:
    https://www.vntweb.co.uk/reset-wordpress-metabox-positions/

    It resolved my issue after carefully following the above article.

    Best of luck!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.