Support

Account

Home Forums General Issues my ACF field is not displayed

Solved

my ACF field is not displayed

  • Hello
    I don’t understand I created one field for which I did Apply custom access settings –> Content accessible to Logged In Users –> I selected the member role that can see the content
    I also created one rule which say the field is shown on user page

    And when I login as the good member role, the field is not displayed on the user’s profile.

    Can you help me please ?

    Thank You.

  • Hi @emvl

    Could you please tell me how did you apply the custom access settings? Were you using another plugin to do that? I believe ACF doesn’t have that kind of feature. If you were using another plugin, could you please disable it to see if it fixes the issue?

    If you are using the PRO version, you should be able to add the field to the profile editor page (backend) by setting the location rule to “User Role <=> is equal to <=> All”. If you are using the free version, you should be able to set it to “User <=> is equal to <=> All”.

    For the front end, you need to use acf_form() function instead. This page should give you more idea about it: https://www.advancedcustomfields.com/resources/acf_form/.

    If that doesn’t work, could you please share the JSON or XML export file of your field group so I can test it out on my installation?

    Thanks 🙂

  • Hi @james,

    Thank You very much !

    I did follow your instructions : I deactivated the plugin Ultimate Member (which manages the roles of users), I specified the rule : “User <=> is equal to <=> All” and “Page <=> is equal to <=> User”
    but still, the field is not displayed.

    I join the export file as asked…

    Thanx 🙂

  • it’Ok it works I just deleted the rule “Page <=> is equal to <=> User”

    thanx

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.