Home Forums General Issues Missing Fields after Export / Import


Missing Fields after Export / Import

  • Hi,

    I hope somebody can help me. I’m trying to make a copy of a site I’m working on, thus exporting and then importing my custom fields (a flexible content field with lots of layout and subfields) via XML export and WordPress Import Tool. For some reason, when I import onto WordPress, some fields work perfectly but this particular Flexible Content field does not get imported properly (it just creates the field but does not display any label and there are no layouts nor subfields). I’ve tried several times and I’m kind of lost.

    Any ideas? I’m using the latest plugin version. Thanks!

  • Hi @elfenoco

    Previous issues have arisen from the import / export process due to line breaks in the xml file.

    Does your field contain instructions that are on multiple lines?

    Removing the line breaks could fix the issue completely

    Hope that helps


  • Hi @elliot

    Indeed, removing line breaks worked! Thanks for your reply. It’s important to note that you have to delete the custom fields created by the failed attempt first or it won’t work (even though the importer shows the success message). I used Coda’s text processor to automatically remove all line breaks from the file (so I wouldn’t miss any) and it worked like a charm.

    Thanks for your reply!

  • I have something simmiliar.

    1) I created a few pages with acf fields.
    2) I generate json file with this fields group.
    3) I clean database and then create programically pages (with same names and slug thats before).
    4) I import acf fields from json file.
    5) I go and edit some page – i can’t see acf fields.
    6) I must edit acf fields group and click Update. Now i can see fields on page edit.

    This is issue?

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Missing Fields after Export / Import’ is closed to new replies.