Support

Account

Home Forums Backend Issues (wp-admin) Media Upload button not showing

Solving

Media Upload button not showing

  • I have a WYSIWYG field in a repeater set to show the Add Media button, but it isn’t showing up. They’re showing everywhere else on my site, but not in one particular field. I tried turning it ‘off and on again’ and it didn’t help.

    I noticed that when I go to the export the field in question looks like this:

    `
    array (
    ‘key’ => ‘field_578d1805c1b32’,
    ‘label’ => ‘Content’,
    ‘name’ => ‘content’,
    ‘type’ => ‘wysiwyg’,
    ‘instructions’ => ”,
    ‘required’ => ”,
    ‘conditional_logic’ => ”,
    ‘wrapper’ => array (
    ‘width’ => ”,
    ‘class’ => ”,
    ‘id’ => ”,
    ),
    ‘default_value’ => ”,
    ‘tabs’ => ‘all’,
    ‘toolbar’ => ‘full’,
    ‘media_upload’ => ”,
    ),
    `

    short of switching to hardcoded fields or editing the database by hand, is there a way to fix this?

  • This reply has been marked as private.
  • ^^^ did you manage to fix this issue? I am having the same issue.

  • Hi @awrightdevelops

    Could you please share the JSON or XML export file of your field group? Also, could you please check if you are using the Local JSON feature? If you use it, could you please backup the files in the “acf-json” folder and then delete the folder?

    Thanks 🙂

  • Same issue here. Using flexible content field with ability for user to select number of columns where each column editor will show its own WYSIWYG. In random columns, the media upload button is missing.

  • Hi @moettinger

    Could you please check if there’s a conflict on your site? Could you please try to reproduce the issue on one of the WordPress’ stock themes (like Twenty Sixteen) with other plugins deactivated? If it disappears, then you can activate the theme and plugins one by one to see which one causes the issue.

    If the issue persists, could you please share the JSON export file of your field group?

    Thanks 🙂

  • Switched to Twenty Sixteen and deactivated all plugins but ACF and issue remains. How do I export my JSON file?

  • Hi @moettinger

    You should be able to export the JSON file from “Custom Fields > Tools”.

    Also, it seems your WYSIWYG field somehow has the Show Media Upload Buttons? set to empty, which makes ACF thinks that it’s set to false.

    To fix it, could you please expand/open all WYSIWYG fields in your flexible content field on the field group editor page and then resave it. You don’t need to change anything, though.

    Hope this helps 🙂

  • Worked for me. Thanks!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.