Support

Account

Home Forums Bug Reports MAJOR: Can't publish anything – ver 5.7.0-beta2

Solving

MAJOR: Can't publish anything – ver 5.7.0-beta2

  • I just updated to the latest version, and can no longer publish posts of any type, including native WP posts / pages.

    I deactivated all my plugins, and reactivated one by one. As soon as ACF Pro is active, I can’t publish anything.

  • We encountered this as well, on Beta 1. Reverting to 5.6.* solves the problem.

  • Good to know. In my case, I didn’t have the problem on 5.7.0-beta1, only after upgrading to beta2.

    I will revert for now – thanks.

  • Same problem here
    (WordPress 4.9.5, all other Plugins disabled, tired German and English….)

  • Hi guys

    Thanks for the posts,
    Elliot here – ACF dev​​​.

    If possible, can you please try our latest build (5.7.0-RC1). We have made a lot of improvements over the past weeks and believe this issue will now be fixed.

    Thanks
    Elliot

  • Same problem here. Cant Publish/Update. Endless turning Arrow in WP Update Button.
    German WP 4.9.6., Custom theme. Lots of Custom Post Types.
    Reverting to 5.6 solves the problem and runs faster.
    Update to WP 4.9.7 -> no change.

    BTW: Thanks Elliot for your outstanding work over the last years and your wonderful pro version which is easyly the most important plugin for me.

  • This reply has been marked as private.
  • We are seeing this issue also. This is after updating to the release version via the WordPress plugin updater. Should I still try the latest RC (RC4 at this point) or is the release version newer?

    We are seeing a JavaScript errors in the console (see attached image), which I think it the cause. I did try clearing cache to see if it was a stuck JavaScript include, but no luck there.

    Also, reverting to 5.6.10 solved the problem.

    Thanks,
    Stephen

  • I’m experiencing the same problem with the latest version, although without any console errors. Rolling back to 5.6 also solved the issue for my site.

    Looking forward to an update.

  • We had the same issue with ACF Pro v5.7.0 and Firefox 52 ESR with one of our government clients. Rolling back to ACF Pro v5.6.10 seems to have resolved the issue.

    Has there been any progress on replicating/fixing this issue? We’re getting reliable replications on our end so let us know if you need any more details!

  • We had a client report that the datepicker field was not working correctly.

    Looking at the console, this.inputText() is not a function was throwing an error in ACF Pro 5.7.0.

    The call should be this.$inputText() and the error was found in the radio field: line 6852 of assets/js/acf-input.js.

    The GitHub repo doesn’t have version 5.7.0, otherwise we would have created a pull request. I’m attaching the files to this comment instead.

  • Had these problems with 5.7.1 too! Went back to last 5.6.x version and the problem is gone. To be precise: the problem only happend on a windows machine, not on Mac!

  • Hi,

    I run WP 4.9.7 with ACP Pro (Developer Licence) 5.7.1.

    I have exactly the same problem: I cannot save a page!

    The only way I found to edit a page is:
    1. Pass the page from Public state to Draft, with the quick editing function.
    2. Modify the page and save as a draft.
    3. Pass the page from Draft state to Public, with the quick editing function.

    When I unactivate ACF Pro 5.7.1 in extension list, this bug is away. So I would like to know where can I donwload the latest previous 5.6.x package of ACF Pro, to fix my website as soon as possible.

    Thank you a lot.

  • Sorry, I wrote ACP instead of ACF… Don’t blame me πŸ™‚

    I saw an ACF 5.6.10 version at this location:
    https://github.com/wp-premium/advanced-custom-fields-pro/releases/tag/5.6.10
    Is it an official version?

    I installed it and now all is OK, no more bug. πŸ™‚

  • I also had to go back to 5.6.10, many users (mainly on Windows) were not able to update or save posts (javascript problem I assume).

    Any updates on this issue? Thanks,

  • I could reproduce this issue with ACF 5.7.1 in an empty wpsandbox.io sandbox using Firefox ESR 52.9 on Windows and OS X.

    Will also try going back to 5.6.10.

  • Same problem here with ACF Pro 5.7.2 and Firefox ESR 52 or the latest Mozilla SeaMonkey (2.49), which is based on Firefox 52 (ESR). (Windows)

    It works with Firefox 61 and Chrome 67.

    No we use version 5.6.10 (thanks for the link, @darrigan).

    Please fix this for 5.7.x, thanks!

  • I’m having this issue since the first beta of v5.
    I just updated to version 5.7.2 and still have the issue.

    The strange thing is that not everybody working on the site(s) experiences it.
    The otehr strange thing is that the page updates can be saved by clicking in the title field and hitting enter. It’s specifically the Publish button that doesn’t work => AJAX stuff.

    Finally – this issue not only affects pages, but menus as well. It’s totally impossible to save any menu change if ACF 5 is active.

  • same issue here

    Wordpress v4.9.8, ACF v5.7.2

    Using Firefox v52.0.2 on Windows

    I can’t save or update a post if ACF is activated.

    If I use Google Chrome, then no problem

  • We’re experiencing this issue as well. WordPress 4.9.7, Advanced Custom Fields Pro 5.7.1. It’s affecting our users on Firefox 52.9 ESR only. Things are fine on Firefox 61, in addition to Chrome. We were previously on ACF Pro 5.5.7 and did not, as far as I know, experience this issue.

  • Fixed on 5.7.5. Works perfectly.

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.