Home Forums Backend Issues (wp-admin) Location Rule Value Always Resets To Post


Location Rule Value Always Resets To Post

  • This isn’t a huge deal, but it’s kind of annoying. I use the basic/default location rule to get my custom field group to show up on my custom post type. It does this quite simply: Post Type -> is equal to -> art_proofs (<- my custom post type in this case). However, I started to notice that every time I want to go in and add/edit any of my custom fields for this group, when I open the field group, the value dropdown defaults to “post” instead of the last value I set (my custom post type). Therefore, every time I add/edit anything in this group, I have to remember to go change the value of the location to my custom post type, otherwise, it adds the group to the “post” post type.

    Again, this isn’t a huge deal, because if I do forget to change it, I just notice my ACFs are gone, so I just go back and update the location value and everything is back. However, this is just annoying.

    It feels like a bug. Not sure why this would be intended functionality. Am I missing something here?

  • Do you have any special characters or spaces in your custom post type slug?

  • I have an underscore. It’s called art_proofs.

  • I tested it with a post type with the same slug and I’m not seeing this issue.

    What version of ACF are you using?
    Have you tried deactivating other plugins and switching themes to see if that clears it up?

  • Tried it with acf4 and still not seeing it. Can you post the rest of the arguments used for creating this post type?

    Actually, I’ve seen this before with my own CPT in the past, but it was quite some time ago. I don’t remember if I figured it out or not.

    Also, do you have any other CTPs created? Do you have custom taxonomies?

  • I’m experiencing this as well. Location sometimes resets to ‘Post’ and at the same time other field group settings reset as well, like Style and Label Placement. Happens with my field group that is assigned to appear in an options page. Field group itself is quite large. Well over 200 fields counting accordion fields etc, could that be the cause?

  • Figured it out, was running into PHP max input variables limit. Increased it to 3000 and everything is fine.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Location Rule Value Always Resets To Post’ is closed to new replies.