Support

Account

Home Forums General Issues JSON syncing not working

Helping

JSON syncing not working

  • Issue concerns JSON syncing. I’ve just started using it a few weeks ago so maybe I’m missing something.

    I’m developing locally.

    ACF version 5.8.7

    I have created a plugin to house some custom Gutenberg blocks and I’m using the JSON syncing feature to ensure that all my fields are created when I install that plugin. So I’ve created save and load points that point to my acf-json folder inside my plugin. But one (out of 5) of the custom field groups, a custom field group with 10 subfields, is not working properly. It’s just an empty group with no subfields.

    What I’ve tried:
    1) Reset permissions (changed a couple times, finally to 777)– this did nothing

    2) Opened the JSON file and manually changed “modified” timestamp to something higher. This looks like it works, for a second, but then it gets undone. What happens is, after modifying the timestamp, I refresh the Custom Field Groups page and I see the Sync Available link. When I click the link, it just refreshes the “All” Custom Field Groups page, instead of taking me to the list of fields available for syncing, and the “Sync Available” tab is gone. And when I return to the JSON file I just edited, it is reverted to the previous version– no subfields, and an unmodified timestamp.

    After this, I tried renaming my custom plugin, copying and pasting the working plugin from the other WP instance, deleting the old folder and reactivating the new copy. Still no dice, so I again 1) changed permissions of the acf-json folder to 777 and 2) tried copying and pasting the contents of the working JSON file into the nonworking version, 3) modifying the date, and 4) trying to sync them in the Admin area. Same result, the sync was no longer available when I clicked the link. But this time, the JSON file didn’t revert back to the unmodified, almost empty version. The subfields are still there and the timestamp is still the modified version, but there are no fields when you look at it from the admin (and no fields when you try to use the block in the Gutenberg editor, of course).

    What am I doing wrong?

  • The same problem.
    I save & load from json fields. Main groups working but subfields not showing in admin panel ( showing when edit post ). Exist in json file but when I try to change fields ( add new ) – subfields are removed from json ( new is added ).

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.