Support

Account

Home Forums Bug Reports JSON Synchronization not working in latest version

Solving

JSON Synchronization not working in latest version

    • Amar

    • February 12, 2019 at 3:14 am

    Using JSON synchronization doesn’t work properly in 5.7.11. We had to downgrade to an earlier version for now. Generally, sub-fields don’t get imported at all. If I have a group field with sub-fields, the group field shows up but not its sub-fields. This happens only when syncing from the Custom Fields. If I copy the JSON and import it manually, it works correctly.

    • Amar

    • February 12, 2019 at 5:48 am

    Looks like this is fixed in the latest beta version. I can’t reproduce this in 5.8.0-beta3.

    • Elliot

    • February 12, 2019 at 11:17 am

    Hi @amarsyla

    Thanks for the bug report.
    I’m very interested in replicating and fixing this issue.

    Does this problem occur when updating an existing “group” field, or when adding a new “group” field via sync?

    • Elliot

    • February 12, 2019 at 11:51 am

    Hi @amarsyla

    I’ve just spend some time testing this issue and was successfully able to replicate and fix the problem.

    Can you please re-download the ACF PRO plugin files and test the issue?

    An easy way to re-download is to edit the main acf.php plugin file and change the version number ‘5.7.11’ down to ‘5.7.10’
    – please note the version number appears twice in this file and both will need to be changed
    – after this change is made, please update the plugin as per normal and it will update to 5.7.11 (including the new fix)

    • Amar

    • February 12, 2019 at 12:32 pm

    @elliot thanks for looking into this! Unfortunately the sync doesn’t work at all now. It creates the field groups, but there are no fields inside them. I’m staying with 5.8.0-beta3 as it’s the only version that’s working correctly for now. I’ll be able to help in solving this if it doesn’t get fixed.

    • Amar

    • February 12, 2019 at 12:37 pm

    @elliot by the way, I am trying this to create fields. I am deleting everything and then trying to re-sync everything from scratch!

    • Elliot

    • February 12, 2019 at 6:47 pm

    @amarsyla Can you please re-download the ACF PRO plugin files and test the issue?

  • I’ve been having this same issue, a co-worker lost all the sub fields in the admin after syncing an update to the acf-json on 5.7.11; Everything had been working flawlessly until the update yesterday, then I tried a sync and lost all my sub fields as well. I sync via an update from him after he ran an import via the admin to import JSON which brought everything back. So right now, we have to import the JSON files instead of syncing and all seems fine…? But we’ve not tested that aggressively.

    I just downloaded the latest pro version from my account today (30 mins ago from this writing), which is still stating it’s 5.7.11 but upon applying those updates still no sub fields saved as they’re all deleted, we can see our fields, it’s just that the json files have all the sub fields removed.

    Reverting the sub field deletion that acf pro 5.7.11 does during the sync and getting the sub fields back we tried 5.8 beta and everything syncs fine just like it was doing on 5.7.10.

  • So, I tried to post earlier and it’s not showing up; Here’s a truncated follow up to the missing post I submitted earlier.

    Syncing appears to still be broken as of earlier this morning, I pulled the latest download from my Pro account which was 5.7.11, applied it to my code base and syncing still deleted all sub fields from my acf-json files. Using 5.7.10 for 5.8 beta everything is preserved when syncing. The only way my dev team could “sync” updates to acf-json on our locals was doing a manual upload of the acf-json files via the importer tool, any sync attempts resulted in deleted sub fields.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.