Home Forums General Issues Issues with saving pages


Issues with saving pages

  • We are experiencing issues with two of our WordPress sites when trying to save pages. Our standard setup is as follows:

    • WordPress version 5.3.2
    • ACF plugin version 5.8.7
    • Classic Editor plugin version 1.5
    • Wordfence and iThemes Security plugins

    We have custom ACF fields on our post/page templates.

    Recently, when we try to update/save a page, we are redirected to https://<domain&gt;.com/wp-admin/post.php instead of https://<domain&gt;.com/wp-admin/post.php?post=11&action=edit, and the changes are not saved.

    As a test, we tried deactivating the Classic Editor plugin and reverted to the Gutenberg editor, and we are able to update the main content/body of a page. However, any changes made to the custom ACF fields are not saved and the “Update” button just sits on “Updating”, even though we receive a notification in the bottom left corner to say the page has been updated.

    Do you guys have any suggestions on how we can troubleshoot and/or resolve this issue?

  • try disabling wordfence and security plugin and see if that corrects the issue.

    try reinstalling ACF (download from your account and upload to the site)

    try reinstalling WP update

    I know that this is not an issue with WP/ACF/Classic Editor. All of my sites run this combo and I’m not seeing any issues.

  • Hi John,

    We have tried disabling the security plugins to no avail, but we haven’t tried re-installing the ACF plugin. If we re-install the plugin, will we need to re-create all of the custom fields and data?

    Any idea why the ACF fields are working with the Gutenburg editor?

  • No, you won’t need to recreate data.

    Generally when things like this happen a file got corrupted in some way. I would just upload the ACF files using FTP to make sure everything is in working order.

  • Hello, was just wondering if this issue was ever resolved? We are seeing a similar problem and it’s very occasional but very annoying. We can’t seem to track it down.

  • Hi spacecats,

    We managed to track down the issue after an exhaustive investigation.

    The issue was caused by a rule in the OWASP ModSecurity ruleset in WHM/cPanel; we had to disable the following rule:


    After disabling that rule we had no further issues with saving posts or other entries in WordPress.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Issues with saving pages’ is closed to new replies.