Home Forums Front-end Issues Issue with Gallery fields after update


Issue with Gallery fields after update

  • Hi all… hoping someone can help with one that’s been bugging me for days now.

    I have a basic gallery field but for some reason when I add it to a post it breaks – it worked previously and I can’t see anything that’s changed.

    One any post that has the field populated I can’t use any ACF functions, even get_fields() results in a break in the page at that point. No PHP error, no JS errors. If I remove the gallery field everything works again.

    The wp_postsmeta looks like this:

    page_container_0_photo_selection: {i:0;s:4:"5060";i:1;s:4:"5073";i:2;s:4:"5092";}
    _page_container_0_photo_selection: field_584ae841a0368

    Where field_584ae841a0368 is an ACF gallery field.

    Can anyone see anything strange there or help with debugging it? Everything on the back end is fine.


  • Ah, is this the correct forum for this? 🤞🏼

  • I don’t know if you fixed this already or not but I was having the same issue.

    I fixed it by adding the post_id to get_fields. I have no idea why this was needed, other than that I was outside the loop, but I’ve never had that issue before when calling a custom field that is specific to a page.

  • Hey @jeff_aka_jefe – I kind of sorted it. I actually added a support ticket and we went through lots of things!

    I think my issue is/was… very large images being uploaded and the site running out of memory before they were fully processed which caused issues for ACF pulling them back.

    Probably. I think. 😀

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Issue with Gallery fields after update’ is closed to new replies.