Support

Account

Home Forums Backend Issues (wp-admin) Incomplete media gallery options in "file" field

Solved

Incomplete media gallery options in "file" field

  • Hello, i’ve got a repeater with some “file” subfields. I noticed that from some moment on the choosing of files of type different from images is prevented.

    for example when adding a media element to main content through “add media” button i got full list of choices, when trying to select a media for a “acf file” field, i’ve got limited ones.

    See:

    http://labs.b42.it/files/acf-file.png

    http://labs.b42.it/files/normal-add-media.png

    This was working before and there’s no media type limitation in ACF field definition.

  • Basically i think it’s showing the “image field” media gallery filter instead of the full “file field”.

    Anyone has any clue?

    there’s people having the save issue even here (but i don’t think it’s related to acf qtranslate)

    https://github.com/funkjedi/acf-qtranslate/issues/122

  • I think it has something to do with the acf-qtranslate, because the standard ACF file field shows all files in media gallery.

  • I just took a look at this and on a test site with only ACF installed I’m not seeing any issue. I’d have to say that this is probably caused by either another plugin or something in the theme. Have you tried deactivating other plugins? Are you seeing any JS errors?

  • I’m having the issue even with ACF – Qtranslate plugin disabled.

    What i see is that i don’t have problems with newly created fields (inside or outside repeaters) but i have with this field that was created with previous versions.

    May be that that database is not correctly upgraded?

  • The only thing that ACF stores about the field in the DB is the attachment ID.
    Everything else about the field is stored as a serialized array in post_content with a few items put into other fields for the post and a couple of meta values. Any problems with this should be evident when you’re editing the field group with the effected fields. What are the settings on these fields? (old ones vs new ones). Are you able to look at any differences of the fields in the database?

  • I think i solved the mistery.. the field was listed as “file” but when i looked at the exported json definition of the field group it became clear it was a
    “type”: “qtranslate_file”, so yes the issue is about acf-qtranslate not ACF.

    In fact changing the field back to “standard file” solved the issue (although i’m not able to link different files in different languages but that not a problem of yours 😉 )

    Sorry for your time loss, you can close the ticket.. and thank you for the great plugin.

    Ciao from Italy 😉

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.