Home Forums Backend Issues (wp-admin) Incompatibility between ACF 5.11.2 – 5.11.3 and ProfilePress


Incompatibility between ACF 5.11.2 – 5.11.3 and ProfilePress

  • Hi, I have always successfully used the two plugins Advanced Custom Fields and ProfilePress on my sites.
    However, starting from version 5.11.2 of ACF (and the same problem also occurs with version 5.11.3), I found an incompatibility with the “Post Object” fields; if the ProfilePress plugin is active:
    – in the custom fields editor it is not possible to save if a “Post Object” field is inserted due to a Javascript error that is triggered
    – errors occur in the editor of pages that include custom fields with a “Post Subject” field
    Deactivating the ProfilePress plugin everything returns to work correctly.
    Have you encountered the same problem? Do you have any ideas on how to fix?

  • What is the JS error that is causing the issue?

  • Same problem… in my case there is “No select2” error in console. All plugins up to date.

  • The error is “No select2/compat/dropdownCss” at line 1361 of

    I think there is a conflict given by duplicate names between this file and an object in

    The same error occurs both in the ACF editor when adding a “post object” field and in the page editor where this field appears.

  • The ACF assistance suggest me this solution, I have tried and it works perfectly!

    Add the following lines in the functions.php file, to avoid ProfilePress loading the “select2” library and use only the ACF one to avoid conflicts.

    add_action( 'wp_enqueue_scripts', 'remove_profilepress_select2', 99 );
    add_action( 'admin_enqueue_scripts', 'remove_profilepress_select2', 99 );
    function remove_profilepress_select2() {
        wp_dequeue_style( 'ppress-select2' );
        wp_dequeue_script( 'ppress-select2' );
  • UPDATE: the new version 5.11.4 of ACF released today solve the problem!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.