Support

Account

Home Forums ACF PRO Image upload not working with ACF Pro 5.0.8

Solved

Image upload not working with ACF Pro 5.0.8

  • Not sure if anyone else is seeing this, but my image ACF fields are not saving an image once I updated to ACF Pro 5.0.8.

    My troubleshooting: I went to the field group, deleted the image field and re-added. When that didn’t work, I toasted the current WP page I was working in and recreated. That still didn’t work.

    So I deactivated ACF Pro and deleted the plugin. Installed ACF Pro 5.0.7 and it’s working now.

    • zaccety

    • September 16, 2014 at 3:27 am

    Roger that, having the same issue here.

  • Me too. Though in my case, i have setup a tab with 2 image upload fields – the second one works, the first one doesn’t. The WP image manager dialog appears fine, but choosing an image and pressing Select, it goes back to the edit screen with no image selected.

    • harryadf

    • September 16, 2014 at 6:48 pm

    I’m also having this issue, I have two repeaters in a group, both with image fields. One works fine, the other only allows certain images to be added. I have deleted and remade the field and re-uploaded images to no avail, would be good to get some light shed on the issue, Thanks.

    • Markus

    • September 16, 2014 at 9:43 pm

    Me too, for some images. Maybe this helps: A ‘url’ property or function must be specified error in Backbone.js

    • Ash

    • September 20, 2014 at 1:52 am

    I’m having the same issue here

    • zaccety

    • September 23, 2014 at 3:22 am

    Helooooo, can anyone on support team confirm whether this is being investigated? I’ve got a big project on which is spec’d to heavily rely on this, it would be good to know (for my clients peace of mind) whether it’s in hand or not.

    Cheers,

    • andiszek

    • September 23, 2014 at 6:51 am

    Hello all,
    i couldn`t upload small images (under 150*150px) as well with the new version until a few days ago. then i re-downloaded the latest version from my account, and it seems that it is fixed – now i can upload any image without any problems.

    try to do the same. Maybe Elliot fixed the bug but forgot to update the version number of the plugin.

    regards,
    andi

    • Markus

    • September 23, 2014 at 6:55 am

    It worked for me one day. After that, the same error occurs again.

  • I’m still holding off on 5.0.8 on all of my sites. Forgot and updated one of them, and then the user support emails started. Had to go back to 5.0.7 and then all image upload problems vanished.

    • 9gdesign

    • September 25, 2014 at 8:14 pm

    Yes im having the 2 issues described here:

    1: Cant upload smaller images
    2: The image uploads to WP but doesnt go into the ACF

    • Glen

    • September 27, 2014 at 2:19 pm

    @theatereleven could you post a link to 5.0.7? I brought Pro yesterday so 5.0.8 is the only version I have and it’s not displaying any new field data on the front-end. I’d like to try 5.0.7. Nevermind, I found links to all previous versions under my account page.

    No change. It appears that version 5.0.8 isn’t able to return field data. Not just for images but for any field type.

    • andiszek

    • September 28, 2014 at 12:07 am

    hi all,
    i think i may have found a temporary fix for the images and fields not saving problem:
    i turned on “local JSON” (see here: http://www.advancedcustomfields.com/resources/whats-new-version-5/#local-json ); now all images and fields get saved in the backend and displayed in the frontend as well.

    try enabling the Local JSON on your projects – maybe it helps until the bugs get fixed.

    regards,
    andi

    • Elliot

    • September 30, 2014 at 3:09 pm

    Hi guys

    ACF PRO v5.0.8 contained a JS bug in the image field when first uploaded. This was fixed within the next day and re-uploaded however, the version number was not changed to initiate upgrade notices.

    If you are experiencing any JS issues selecting an image, please re-download the ACF PRO plugin from your store account and copy over the js folder.

    Sorry for the bug, and the inconvenience. Please let me know if this solves the issue, or if there is something else.

    • zaccety

    • September 30, 2014 at 7:17 pm

    That’s great news.

    I’m not having a go, but two weeks is a long time to have left this thread hanging…

    Cheers

    • 9gdesign

    • September 30, 2014 at 7:25 pm

    Hi

    I have 20 sites using this so is there no way to update these with the usual update as you do? Or do i have to manually upload the updated JS folder to each site?

    And i agree 2 weeks is a long time for a product that is widely used and effective 🙂

    • 9gdesign

    • September 30, 2014 at 7:35 pm

    Sorry but its still not working. I tried uploading the new JS folder in both the root plugin folder and the JS in the PRO folder.

  • Hey thanks Elliot. I did in fact download again today and tested – BOOM. It’s working.

    And Elliot, we can say thanks enough for ACF. WordPress wouldn’t be WordPress without it.

    • Elliot

    • October 1, 2014 at 12:45 pm

    Hi @9gdesign

    Can you please perform a hard refresh and test in your console log that the function exists:

    acf.fields.image.prepare?

    Thanks
    E

    • Elliot

    • October 1, 2014 at 12:46 pm

    Hi guys,

    As for the 2 weeks thing. Please remember that this is a community forum, not a support forum. If you wish to have one on one support, this is offered via the helpdesk here:

    http://support.advancedcustomfields.com/

    Thanks for your help

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.