Support

Account

Home Forums Backend Issues (wp-admin) Illegal offset

Solving

Illegal offset

  • Hi,

    Suddenly ACF isn’t working. I’ve not altered anything.

    This is all happening in the backend. I have a number of custom fields that are attached to new posts. Up until now these have worked perfectly. Now, when I try to save new posts I get about 50 errors along the lines of:

    Warning: Illegal string offset 'order_no' in C:\wamp\www\aa1\wp-content\plugins\advanced-custom-fields\core\controllers\field_group.php on line 907

    Further errors refer to ‘key’ being illegal as well as ‘type’. All of these are happening in ‘wp-content\plugins\advanced-custom-fields\core\controllers\field_group.php’ or ‘wp-content\plugins\advanced-custom-fields\core\fields\_functions.php’ and then ‘wp-admin\post.php’ and ‘wp-includes\pluggable.php’when I get told the headers have already been sent.

    I’ve tried uninstalling and reinstalling the plugin, turning off all other plugins and upgrading WP to the latest version – nothing works.

    Any pointers would be gratefully received.

  • Hi @kevleitch

    Could you please share the XML export file of your field group? Also, have you tried to reproduce the issue on one of WordPress’ stock theme? Maybe there’s a function in your theme that causes the issue.

    Thanks πŸ™‚

  • Hi James πŸ™‚

    XML file is here: https://dl.dropboxusercontent.com/u/167786/advanced-custom-field-export.xml

    Changing theme to 2014, 2015 or 2016 makes no difference, same errors.

  • Hi @kevleitch

    I’m afraid I can’t reproduce this issue on my installation. Could you please try to re-save the field group and test it again? If you want, you can also try to export the field group, delete it and then import it back. Please backup your site and database first before doing it.

    If that doesn’t help, could you please open a new ticket and provide temporary admin credentials to your site? You can open a new ticket here: https://support.advancedcustomfields.com/new-ticket. Also, please don’t forget to explain the issue again and provide the link to this thread.

    Thanks πŸ™‚

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.