Support

Account

Home Forums Backend Issues (wp-admin) I cannot View the Custom Fields Anymore

Solved

I cannot View the Custom Fields Anymore

  • Greetings,

    I installed the ACF plugin and has been using it to manage my page.

    But from yesterday i cannot see the fields in my page. What could be the issue?

  • I have the same problem. I am using ACF to add a couple of custom fields to our Woocommerce product records. As of last week, we can no longer see the custom fields. They are still in the database, but are not accessible to edit.

    Any help on how to restore their view would be greatly appreciated, as this is causing a real problem with website maintenance.

  • Are you on WordPress 5.3.0? Are you using Gutenberg or the Classic Editor?
    What version of ACF are you using?

    I am having this same issue with Gutenberg on 5.3.0 with ACF 5.8.0 Beta3, and I tried a few things to get them to show up again.

    1. In Gutenberg, go to Options > Advanced Blocks and see if the names of all your metaboxes are showing up there. Make sure they are all checked. Only two of mine were showing up.

    2. Check the DOM to see if they are loading at all. (Inspector)

    3. Create a new Admin user account, and go to the page edit with that new account. My issue had to do with permissions somehow, and this made the fields show up for a few hours. But then they all disappeared again.

    Reverting back to ACF 5.7.9 fixes everything for me.

  • We managed to fix it using a different approach.  

    We re-added the group and fields in the ACF setup, being careful to name the fields the same as what they were named before. The fields then reappeared in the Woocommerce Product records, and the data reappeared in those records that previously had data in the fields.

    Not sure what made the field definitions disappear in the first place, but I am suspicious of the latest plugin upgrade.  

  • I also figured out what the issue was for me: the field drag and drop in Gutenberg was causing the metaboxes to disappear when the page was refreshed (not JS reload). Had you been moving the metaboxes around with the drag and drop, do you remember?

  • Thanks guys for the replies, i also figured out my issue. I had two identical WordPress page templates. So the plugin was getting confused 🙂 with which page to display my fields.

    Regards.

    Out

  • Hi,
    I have the problem that the fields are also not displayed to me, or not loaded. In edit mode, I see the fields and content, so I started the database update again as described in the FAQ. Unfortunately without success. I use the fields to embed javascript and CSS on two pages. Unfortunately this code will not be loaded.
    Today from 4 to WP 5.0.3. ugedated, since then the problem occurs.
    Many Thanks

  • I’m sorry, my mistake. Of course you should not forget an edit in the header and footer 🙂

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.