Support

Account

Home Forums Bug Reports Hide On Screen not Working after WP 3.9 Upgrade

Solving

Hide On Screen not Working after WP 3.9 Upgrade

  • I commonly turn off the default content editor visibility using the “Hide On Screen” options at the bottom of a field set. This isn’t working with WordPress 3.9. Selecting “Content Editor” does nothing to hide the default content editor when editing a page. ACF Version 4.3.7

  • Hi,

    Are you using a custom post type, page or post?

  • I’m also seeing this on a 3.9.1 site. If I put a check mark in hide content editor and hide featured image and click update, the checked boxes uncheck themselves.

    So I tried telling the ACF fields to show after Title – that didn’t save or work either. However all other custom field settings are saving and working without issue.

    This site is a site built with the Roots starter theme. I’m using several plugins in addition to ACF like CF7, BackupBuddy, WordFence and responsive lightbox.

    To answer the question above, mine is on a page. I’m telling ACF to show the fields for a certain page.

  • Another update on this – I just tried it on a completely separate WordPress 3.9.1 site, and it’s doing the same thing. It will not save the settings that are checked. Everything else is working – it just won’t hide things or re-position.

  • I later discovered that I had not applied the correct template to the page and the settings for the field-set were assigned via the template. After changing the template, it started behaving correctly. I apologize for reporting this issue as a bug when it turned out to be my own mistake.

  • Gotcha.

    Mine is still a bug.

    If I check settings such as “Hide Content Editor” ACF is not saving the settings since WP 3.9.1.

    I’ve verified this on two different sites with the latest ACF plugin.

  • I’m not sure if this is exactly related, but I’m experiencing something similar. On a page (among many) using a particular template with custom fields, I wish to hide one custom field. Using the screen options at the top of the edit screen, I uncheck the field and it goes away. Upon updating the page, the box remains unchecked yet the field remains visible.

    Running WP 3.9.2 and ACF 4.3.8

  • This problem has gone away for me with ACF v5

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.