Home Forums Backend Issues (wp-admin) Google Maps – Location not found: REQUEST_DENIED


Google Maps – Location not found: REQUEST_DENIED

  • Hello! I have added a field for Google Maps and have an existing API key that is working correctly, has unlimited map loads, etc.

    However, in the WP-Admin, when I click on a point on the map to set an address point or try to search for one, I get an error above the map — Location not found: REQUEST_DENIED — as well as a console error “Geocoding Service: This API project is not authorized to use this API.”

    I wondered if anyone has run into this problem before. Again, my Google Maps API Key is set and working correctly (and counting), it’s just not recognizing it here. I’d appreciate any insight!

  • Hi!

    Make sure you activate both Google Maps Javascript API as well as Places API in the Google Console. The function you are trying to use is using the Places API.

  • Thank you! This solved my issue. I didn’t have Places API enabled (I didn’t notice that), but that didn’t solve it right away; after digging around, I also had to enable the Geocoding API, and now it works.

    Thank you OyvindLille!

  • Glad it worked out, @brosenbaum_tep 🙂
    I’ve never needed to activate Geocoding API for ACF maps before, so it might just been som delay? You could check your google console stats to see if you get any hits on Geocoding API 🙂

  • It is getting hits, so it must require it. Thanks again!

  • Good morning guys. It still doesn’t work for me

  • Afraid it doesn’t work for me either. All required APIS added (I think!)

    APIs and error

  • Adding Geolocation API and Places API worked for me! It didn’t work immediately, but after I took the time to register for posting comment on this website (~10 minutes), I refreshed my WordPress editor and entering a GPS coordinate worked!

  • Adding Maps Javascript API, Geolocation API and Places API worked for me too! Thank you all

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Google Maps – Location not found: REQUEST_DENIED’ is closed to new replies.