Support

Account

Home Forums Backend Issues (wp-admin) Google maps API field issue

Solving

Google maps API field issue

  • Hi.
    I have google maps field and suddenly got this error of missing API key and got this error.
    i add the actions and filter that i saw in other topic:

    
    function my_acf_init() {
    	
    	acf_update_setting('google_api_key', 'my api key');
    }
    
    add_action('acf/init', 'my_acf_init');
    
    function my_acf_google_map_api( $api ){
    	
    	$api['key'] = 'my api key';
    	
    	return $api;
    	
    }
    
    add_filter('acf/fields/google_map/api', 'my_acf_google_map_api');
    

    and the maps show on page but when i want to edit the map i got this error

  • I got the same this morning.
    You have to increase the limitation on the Google API Panel.
    To achieve that, you have to creat a billing account on Google Dev.

  • I experienced the same thing but found a solution.

    In the Developer Console, I received the following feedback:
    This api project is not authorized to use this api

    The solution:

    Enable the following APIs:
    – Geolocation API
    – Geocoding API
    – Maps Embed API
    – Maps Javascript API

    And of course enable billing

  • Update. The following is needed as well:

    – Places API

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.