Support

Account

Home Forums Backend Issues (wp-admin) Google Map field in admin throws error when adding address

Solved

Google Map field in admin throws error when adding address

    • ceebeez

    • January 11, 2019 at 1:50 pm

    I’m having an issue with google maps in the admin. My API key has been added as described in the map field docs, and the maps display correctly in both the front and back end, but only when trying to add an address do I get the error shown in the screenshot indicating that there’s an issue with the API key or Google account, though both appear to be fine.

    I see that someone else had the same issue and it was solved but the answer is private.
    https://support.advancedcustomfields.com/forums/topic/admin-map-not-working-when-i-try-to-insert-location/#post-81740

    Does anyone have any fixes for this?

    Thanks,
    Craig

  • I was just having this same issue, the fix for me was enabling the Places Api in the Google Developers Console.

    • ceebeez

    • January 13, 2019 at 9:19 am

    Thanks whiteunicorn, that fixed the issue right away. I really appreciate you taking the time to answer!

    Devs, perhaps the docs for the Map field should be updated with this fix?

    Thanks again.

  • Hello friends! I have solved my problem. You need activate your api keys for Google Maps on Google Cloud Plataform: https://cloud.google.com/maps-platform/user-guide/pricing-changes/?apis=maps,routes,places

    After activate will be generate a API Key, and you can use it on the ACF Pro. I solved my problem this way.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.