Home Forums Front-end Issues Get Field not Posting


Get Field not Posting

  • Code:

    	    <?php if( get_field('manual') ): ?>
    				<button><a href="<?php the_field('manual'); ?>" class="btn">DOWNLOAD CATALOG</a></button>
                <?php endif; ?>

    Field Label: Manual
    Field Name: manual
    Field Type: file
    Return Value: File URL

    In the post, I am able to link to a .pdf file and it does show that the file has been selected, but the code above is not posting the information and creating a link.

    Not sure what’s wrong. Anyone?

  • There is another topic that is similar to this one, you may have something in common.

    I reverted a site to 5.3.5, added fields and values like the ones that are having problems with (post object, image, etc) and then updated to 5.3.6. I’m not seeing any issue.

    What other plugins are you running? theme? You’ll need to narrow down where the conflict might be by disabling plugins and possibly trying on one of the default WP 20XX themes.

    This appears to have something to do with fields that save ID values, not that I know what that might be.

  • So you’re suggesting I revert back to 5.3.5 and start all over again and then update? There’s no fix?

  • I don’t know if their is a fix of not. I can’t reproduce the problem with the information I have and only using ACF and a default theme. I wouldn’t be the one to fix it anyway, all I can try to do is help you help me locate what’s causing it, if we can identify something specific then I might be able to help or point you in the right direction. When there is a problem that does not appear on a site that only running acf the next step is to deactivate other plugins and see if that clears the problem up.

  • And while I was replying to this it appears that the reason that I’m not seeing the issue is that it was fixed. See the other thread I posted. You must have update during the small window while this bug existed.

  • Anyway, just in case you don’t look, this bug existed for only moments and then the developer fixed it. You need to re-download the new version and reinstall.

  • I had the same issue and just reinstalled the most recent version and that fixed it for me too.

  • Well I can’t say it worked for me.

    I reinstalled the latest version (I already had it) and still nothing is posting in the frontend. It doesn’t make sense to disable the plugins because I have other ACF fields developed and they post just fine in the frontend.

    So I went in a disabled most of the plugins (all but two: ACF and Woocommerce) and still nothing posting on the frontend.

  • The developer said that he’s going to release an incremental version for those that got the buggy update. it should be out soon

  • Well I’ve managed to get it working, although it’s the querest thing. I guess I’ll have to wait to see what the developer comes up with and see if it happens again.

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Get Field not Posting’ is closed to new replies.