Support

Account

Home Forums General Issues Front end not showing fields

Solving

Front end not showing fields

  • I have been asked to take over a website that was put together using ACF. The whole site’s layout seems to be managed using ACF fields. I’m new to ACF and am very impressed with what it can do.

    I had tried making a simple change to the Home page by adding a field that was to contain Adsense script. It seemed to be working (although no ads had come through yet), when suddenly the content part of the Home page would not display — only the top menu and footer; all of the content and layout in between that are provided by ACF fields is now missing.

    There are a number of reasons why this might have happened, and since I was making changes to the fields, this seems a logical place to start looking. I brought the page back to a previous version (that had been working fine), re-updated the field group and Home page, but the problem remains.

    View Source seems to show that the field code is not being sent to the browser, and yet the Edit page screen shows all the fields to be correctly in place. I’ve saved and re-saved the field group and page, and double-checked the field and group settings. But the View Source still shows the fields are not making it to the browser. I’ve checked this in both Firefox and Chrome.

    Is it possible that something is stuck in the cache through ACF somewhere? I just can’t find any other reason why the page shouldn’t be generating properly, and some kind of caching function in ACF seems like it might explain why. The site does not have any caching plugins that I can see (none that are dedicated to that purpose anyway). I haven’t tried installing a plugin yet that would clear the cache, as I don’t want to risk making a bad situation worse.

    Thank you in advance for any help with this.

  • Could you post the code you’re using to display the home page content and the new field you created?

  • Hi HQ80, thanks for your reply. I had deleted the new field right after the problem occurred, in case it was something about the field that I had messed up. Not sure how to go about getting the code for that page.

    In any case, it turned out that the template used for that page just needed to be reset in WordPress and the problem was solved. I’m not sure why or how the template got changed, but that’s what finally solved the problem.

    So it may or may not have been anything to do with ACF. Maybe by changing the field group for that page (adding, then deleting, a new field), it reset a bunch of settings, including the page template? There were other settings for the field group that had to be reset too, as I recall.

    Thanks very much for offering your help.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.