Support

Account

Home Forums Backend Issues (wp-admin) Foreach: data-type = 'group'

Helping

Foreach: data-type = 'group'

  • Hi,
    I have a problem with foreach with data-type = ‘group’.
    Maybe someone could suggest something. Can I define value differently?
    I have this:

    <?php
    
                $fields = get_field_objects();
    
                ?>
    
                <?php if ($fields): ?>
                    <div class="slider slider-for">
                        <?php foreach ($fields as $field): ?>
    
                            <?php if ($field['value']): ?>
                                <div class="slider-nav-box-big" id="<?php echo $field['name']; ?>">
                                    <div class="col-md-4 col-sm-12 col-12 slider-for-img">
                                        <img src="<?php echo $field['value']; ?>" alt="">
                                    </div>
                                    <div class="col-md-8 col-sm-12 col-12 slider-for-description">
                                        
                                            <span><?php echo $field['label']; ?></span>
                                            <?php echo $field['wysiwyg']; ?>
                                        
    
                                    </div>
                                </div>
                            <?php endif; ?>
    
                        <?php endforeach; ?>
                    </div>
                <?php endif; ?>

    $field[‘value’] obviously returns an empty Array, and $field[‘wysiwyg’] doesn’t work at all.

  • The value of the field will always be in $field['value'], what format that value is in depends on the type of field it is and what the return format is set to if that is an option available for the field.

    For example, and image field can return an ID, a URL or an array of information and this is what you’ll find in $field['value']

    I’m not sure what you mean by data-type = ‘group’.

    wysiwyg is not an index of $field

    Are you sure you want to be using get_field_objects()? https://www.advancedcustomfields.com/resources/get_field_objects/

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.