Support

Account

Home Forums ACF PRO Flexible Content – Problem if is too many fields

Solving

Flexible Content – Problem if is too many fields

  • I have been use ACF Pro from when I started work with WordPress. I think that this is great tool to fast make websites.

    Very oft I use Flexible Content to build pages – customers and content managers are happy with make pages with this module.

    In last time I saw problems with create fields for Flexible Content.

    I use this method to save fields details: https://www.advancedcustomfields.com/resources/local-json/

    In tab “Sync availble” I see my group: “Flexible Content – group_5a3d44418d526.json”. Then I click “sync” link. My group have 4 fields – one of is flexible content.

    I have defined 23 layouts with 243 fields. File group_5a3d44418d526.json have 234KB and 5230 lines.

    When I try add new field to layout and save this change then I see that in my directory created is new file: group_5a3edb613ffa2.json, and previous file was not modifed.

    When I compare two files then I see differences. Some fields was removed, some fields was move to another layout, settings of visibility field group was changed (remove location, hide on screen), and new field not exists.

    I use PHP 7.1.12, ACF Pro 5.6.7 and WordPress 4.9.1

    This is importat bug in my opinion. If I did’nt use local json and GIT, I probably would not know about the problem.

  • I found resolve for this problem 🙂 I change value for max_input_vars in php.ini for 10000 and all is OK.

    I think that should be notice before save about this problem because peopl can lost their changes

  • There is a plugin that will alert you to problems with max_input_vars https://wordpress.org/plugins/wp-max-submit-protect/

    I use this plugin on all sites that I’m developing.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.