Home Forums Bug Reports Flexible content not saving fields


Flexible content not saving fields

  • Hi,
    Since some days ago, there is a problem with my custom fields (flexible content). It is not saving what I modify…
    I though that it might be a problem with the DDBB memory, but I doubled and it didn’t solve it… Also I tried to deactivate the other plugins, but still not saving the fields…
    Could you help me with this?

  • how many fields are on the page? If there are a lot of them it could be the php setting max_input_vars. Try this plugin, it will warn you when you are exceeding the value.

  • I’m having the same issue, except editing the flexible contents save, but the admin area doesn’t show my changes. There are missing fields on the edit page, but the fields still exist when configuring them. Very strange.

  • Having a similar issue with v 5.5.2. I have the following setup:

    Flexible Content Field
    – Repeater Field
    — WYSIWYG Field

    When I save the page, the WYSIWYG field is blank. If I move the WYSIWYG field out of the repeater, then the content saves for some reason.

    ** Reverting to v5.3.9.2 has fixed the issue.

  • Hi,
    Thank you all for your quick responses.
    I found what was breaking the flexible content and it was due to another plugin setting… Nothing to do with ACF plugin.
    Thank you

  • What plugin was causing your issue? Maybe one of the others having this problem is using the same plugin.

  • It was the Custom Post Template By Templatic

  • Sharing my solution just in case it helps someone since it wasn’t related to rogue 3rd party plugins or bad code in the functions.php file.

    In my case the issue was due to me not adding a field label to the flex-content field in order to avoid redundancy in the admin UI and by extension, the field name was mistakingly left blank. Started working after adding a field name (label was still intentionally left blank).

    Super weird that field name isn’t marked as required when creating new fields.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Flexible content not saving fields’ is closed to new replies.