Support

Account

Home Forums Backend Issues (wp-admin) Flexible Content Layout missing from select

Solved

Flexible Content Layout missing from select

  • So I’ve got 11 flexible content layouts in a flexible content field and the last one I tried to add, “Quick Links”, isn’t showing up in the post editor. Please take a look at the screenshots

    My website has been having a lot of issues with the flexible content field. When I tried to clone one post type’s flexible content field into another custom field group, not everything copied over. So instead, I decided to just use the same field and apply it to the first custom post type and then to the other page that needs it. Now I have that singular flexible content field applied to two places and I cannot get this newest layout to work.

    At first, I tried to add the latest layout by duplicating a similar layout and modifying it but that didn’t work. Then I deleted that layout and re-added it manually; adding the fields as necessary by hand, which also didn’t work. I tried renaming the layout but that didn’t work. I tried adding just a blank layout and that didn’t work either. I attempted to copy the page and add this field group to that new page and I still can’t get the layout to work.

    Is there a maximum number of FC layouts that needs to be overridden? How come my layout isn’t showing up?

  • You may be having an issue with PHP’s max_input_vars setting. https://www.google.com/search?client=firefox-b-1-d&q=acf+php+max_input_vars

  • @hube2 thanks for the quick response. I don’t believe that is the problem since I just updated the phprc, which is what this Dreamhost server is using, to include the following:

    ; {{{ The following lines were automatically added by DreamHost
    zend_extension=opcache.so
    memory_limit=500M
    ; }}} That's all from DreamHost
    
    max_input_vars = 5000
    max_input_nesting_level = 128
    max_execution_time = 300
    post_max_size = 32M
    max_input_time = 300
    suhosin.post.max_vars = 8000
    suhosin.request.max_vars = 8000

    I can verify that everything except the suhosin settings are applied. I’ve tried updating both post and custom field group and nothing is changing. Anything else you can think of?

  • I also tried deactivating all plugins except for ACF Pro during this process. So I was at a loss as to what could be the issue.

    What I then tried was to bring up my local dev environment version of the website and decided to leave the database untouched but synchronize the custom field groups with the acf-json files. When I did that, even though the field group in question had changed dramatically and the synchronization added to older unused versions of the field group, the field group showed the missing layout.

    So I’m not sure what exactly was the issue but it seems that the pending synchronization with acf-json caused some issue. Once I did the same action on the live server, the layout showed correctly. Additionally, I was able to delete the old field groups that synchronized without harming my other data etc.

  • A field group with flixible content fields can easily go beyond 5000 input fields when editing. This plugin, while it has not been updated in a while, still works perfectly well https://wordpress.org/plugins/wp-max-submit-protect/

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.