Support

Account

Home Forums Add-ons Flexible Content Field Flexible Content issues

Solving

Flexible Content issues

  • Hi there, i am having the following two issues with ACV Custom Content/Layout module:

    1. LOCATION RULES
    (show this field group if post type is equal to…)
    It seems i can only have a max of 20 rules.
    Is this a bug or a standard restriction?

    2. FLEXIBLE CONTENT
    Selecting this type of custom field adds a “Layout” section, listed in the left column. On hovering over the layout title with the mouse, the following options appear:

    Reorder | Delete | Add New | Duplicate

    However, clicking any of these unfortunately does absolutely nothing. Btw, my flexible layout group has 7 Layout sections… could this be a factor.

    Please help!
    Justin

  • Hi @goldengekko

    If the flexible content buttons are not responding, there is most likely a JS error on your page which is causing the issue.

    Please check for any JS errors in your console log.

    This would also explain why you can’t add any new location rules.

    Thanks
    E

  • Elliott, I am having an identical issue to Justin.

  • Elliot, opening the browser’s console, i see that clicking on these flexible layout buttons does not even attempt to run any javascript…

    Here is the HTML code for the one of the layout buttons:

    <a title="Add New Layout" href="javascript:;">Add New</a>

    All other layout buttons are coded the same…
    Does this help arouse any ideas??

    Thnx

  • Hi @goldengekko

    Your comment is not correct, an HTML element does not require JS in the ‘onclick’ attribute to work. jQuery uses JS in a separate file to attach JS events to elements in a cleaner fashion.

    As for the issue, please check your console log for any JS errors when you click or on page load.

    Thanks
    E

  • Uncaught TypeError: Cannot call method ‘hasClass’ of undefined
    ^ load-scripts.php – line 261

    Uncaught TypeError: Object [object Object] has no method ‘dialog’
    ^ post-edit.php – line 105

  • Hi mikkel.lindblom,
    Are you using ACF Flexible Layout with WPML already installed?, If yes, this issue was solved in my case updating WPML to current last version.

    JPM

  • Thanks for the answer, i am running WPML 3.1.4 (Latest ver.). It is still not working.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Flexible Content issues’ is closed to new replies.