Home Forums Gutenberg Fields showing on all Pages despite Field Group location rules.


Fields showing on all Pages despite Field Group location rules.

  • I have Field Groups set with Location Rules (certain custom post types, on the homepage), but everything still shows up on all pages (albeit as blank sections with only the heading + collapse arrow). I am using the latest WordPress, ACF and Gutenberg (no Beta versions on anything).

    Deactivating Gutenberg and activating Classic Editor fixes the problem.

    Field Group Example –
    Home Page Admin –
    Blank Page Admin –

  • I just observed this same issue on our main website which relies heavily on Gutenberg. Definitely ignores ACF post type rules when Gutenberg is activated. If I keep Gutenberg activated but also activate Classic Editor, problem goes away (but I don’t get all the editor goodness of Gutenberg).

  • It looks like this might be the same issue / related to this thread:

    If it is, ACF have reported that it will be fixed in v5.8.

  • Yes, that is the issue I’m seeing. Glad to know a fix is on the way.

  • Seems fixed in 5.8-beta2 😉

  • Are those betas available anywhere for download/installation? I’ve got clients giving me some serious stink-eye about the mess in admin right as they’re smack in the middle of populating content for the launch of their new website, and I’d sure like to resolve this for them ASAP if possible.


    Edit: figured out that they’re available through the account screen (I’d previously looked at the github repo to no avail).

  • I’ve now tested 5.8-beta3, and it does fix the issue for me as well. Whew!

    Thanks ACF team for tackling that!

  • I’m experiencing this issue in 5.8.0, after updating to 5.8.1 it still persists.

  • We’ve been experiencing this problem since the release of Gutenberg as well. Weirdly, it has persisted despite our having installed and activated Classic Editor, and no version up to 5.8.1 has fixed it either.

    (Note: Our WP is a multi-site/network installation, and Classic Editor is network activated rather than activated individually per site. Not sure if this would make any difference, but since it’s an unusual configuration I figured it was worth mentioning.)

  • This seems to be happening to me, I have set post types > post but the fields are showing everywhere. Was this fix applied to pro?

  • Did anyone ever find a reliable fix for this? We’re still running into it. Very frustrating for our content editors.

  • Same issue here. The ACF set for specific posts show up on all posts, pages, and even in the media attachment details.

    I have 3 sites with the same setup and did an export/import of the ACF set into this last site where the issue is happening, but not in the other two.

    I disabled all plugins and the theme, switched them back and still got the same result.

    Any ideas on fixes?

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.