Home Forums Backend Issues (wp-admin) Fields not saving, get_field not defined and more


Fields not saving, get_field not defined and more

  • Hey guys, i have this weird issue with a site built on top of ACF:

    1. the site was built on ACF 3 (or 4), with ACF placed in mu-plugins and PHP 5.3 on the server;
    1.1. but upgraded to PHP 5.6
    1.2. and upgraded to latest ACF 5.x;
    2. either existing fields AND new fields are not saved;
    2.1. these are simple fields, texts and datepickers (so no nested repeaters, clones or anything more… exotic)
    3. add_action(‘save_post’) will throw get_field as not found;
    4. WP_DEBUG on will NOT throw any error, warning or notice;
    5. on local server, things are working just fine

    The client cannot pinpoint if the issues are the results of PHP upgrade or ACF upgrade, since he noticed the issues weeks after upgrading.

    Oh, and phpinfo is blocked, so i can’t really tell what’s different there…
    Here are the usual suspects values:

    max_input_nesting_level: 64
    max_input_time: 60
    max_input_vars: 1000
    post_max_size : 128M

    PS this is a cross-post from FB group

  • Hi @iamntz

    You need to upgrade ACF 3 to ACF 4 first before upgrading it to ACF 5. To upgrade ACF 3 to ACF 4, kindly check this page:

    To upgrade ACF 4 to ACF 5, kindly visit this page:

    Also, please make sure that the database upgrade is successful.

    Hope this helps πŸ™‚

  • Right, but this shouldn’t be present on both my machine and production? I mean is the exactly same DB & files.

    I’ll try to force the upgrade though, maybe this will help.


  • And what if it doesn’t work? πŸ™‚

    I just tried to test it on a freshly installed WP & ACF, fields not saving.

    I’m somehow 99% that’s a server issue, but i have no idea where to look at. Any hints?

  • Hi @iamntz

    That’s weird. Could you please try it on another server? You can also try it on your local machine.

    Also, could you please check the PHP error on the server?

    Could you also increase the max input settings on the server? This page should give you more idea about it:

    If it’s possible, could you please share the JSON export file of the field group so I can test it out on my end too?

    Thanks πŸ™‚

  • @james, I stated at first on locally works just fine. No error, no warning, no nothing.

    The server admin made it work though; I’m waiting for his reply and know what was going on.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.