Support

Account

Home Forums General Issues Field not saving

Solving

Field not saving

  • Just come across this very funny bug with the 5.1.7.1 PRO version. If you add the text “SELECT whatever FROM somethingelse” to a text field (tried with text, multiline, wysiwyg) the field will not save, and the admin is just loading. Not exactly sure why is this happening, I presume trying to run it as a command, for now I just changed the O in FROM to 0. Any idea how this could be fixed ?

  • I have exactly the same issue and am working on it right now.

  • Same here…

    If i create new page, the value of the custom field is saved, but on page before i installed the plugin, no value are saved…

    Very frustrating right now…

  • there is another command like text that will not save: UPDATE something VIEW something

  • Hi guys

    Just to confirm, the issue here is the inability to save a text value when the text value is an SQL command?

    There has been no logic updates in ACF to explain this issue, but perhaps the issue stems from a recent WP update? Are you able to downgrade ACF and test older versions to see if this is the case?

    Thanks
    E

  • I did some tests with a fresh wp4.0.1 install, and acf-pro-5.1.7.1

    Running it locally on my computer works fine, running it on the server it does not. Now the server does have a SSL certificate installed, probably this is the problem, will try on a non secure server to see if still happens.

    There is something going on at ajax validation (or rather nothing is going on), so when you press save/update the spinner just going round and round.

    As a temporary solution disabled validation in core/input.php , CHANGED ‘validation’=>args[‘validation’], TO ‘validation’=>0 and the pages will save this way.

  • Fresh wp4.0.0 and acf-pro-5.1.0 with no SSL works, updated wp to latest, works, updated ACF to 5.1.7.1 still works.

    It looks like the problem is the ajax validation when server have a SSL certificate.

  • Hi @robert.pal

    I wonder if it due to some server based security.
    There is a known issue with some servers tripping up when saving a URL value, so perhaps this is the same problem.

    The solution in these cases was to add the following to the .htaccess file:

    
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
    

    Hope that helps

  • Adding that to htaccess make no difference I’m afraid.

  • Hi @robert-pal

    Did you find a solution for this issue?

  • Hi @elliot, no, I haven’t found a solution for this, other than to disable validation as I described in an earlier post. I don’t know if this is good or bad, but had to do it as the website, where run into this problem, is a training website, full of SQL like commands content.

  • Hi @robert-pal

    Thanks for the info.

    Are you able to check your console log when submitting the form.
    The console log will show an ajax request to validate the data. If you have WP_DEBUG mode on (http://www.advancedcustomfields.com/resources/how-to/debug/) you should see some PHP errors in the returned JSON.

    This will help to explain where the problem lies

    Thanks
    E

  • Yeah, I been doing that and found this error:

    XMLHttpRequest cannot load https://pawsinteractive.co.uk/403.shtml. No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘http://pawsinteractive.co.uk’ is therefore not allowed access.

    the test site itself runs on http://pawsinteractive.co.uk/projects/acuity

  • Hi @robert-pal

    Any update on this issue? Would you like me to login and do some debugging on the site?

  • Well … the site gone live now, so can’t give you access to it. I was trying to replicate the problem with the latest version of ACF, but it looks like is working now. The problem could been me mixing https with non https on the test server.

  • Hi @robert-pal

    Thanks for the update. Let me know if you have the issue again and we can do some debugging

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.