Support

Account

Home Forums Backend Issues (wp-admin) Field Groups Not Showing

Solving

Field Groups Not Showing

  • Hi!
    The editor does not show in the table groups I have added but shows the count of that have been published.
    I have no Javascript errors.
    Wordpress Version: 4.5.2
    ACF version: 4.4.7

    My Error

  • So you added a field group through the ACF admin and it does not show in the list? That’s odd, and it’s not happening on my test installation. Start deactivating other plugins. If that does not work the switch to an unmodified default WP theme (2016, 1015, etc). Try to narrow down what’s causing the issue.

  • Hi John! Thank you for your quick response.
    You’re right, I added field groups but they aren’t shown in the list. My field groups are already on my database and the ACF show the number of the published field groups.
    I’ve switched my theme and I have only 2 plugins activated ACF – Custom Post Type UI and Rest API but ACF still doesn’t work.

  • Try reinstalling ACF and if that doesn’t work, try reinstalling WP. The only thing I can think of at this point not related to other plugins or the theme is that there is a corrupt file on the server. Beyond this the only thing that could cause it is that there’s some type of filter or something else interfering with the query.

  • Hi,

    I am getting the exact same issue. Strangely, it did work properly for 3 months now, so I did create 22 fields groups as I do have various custom post type. It is becoming quite blocking, as I cannot get access to the field groups for modifications easily, and I am at the ending stage of the current project…

    Almost all the plugins installed are custom.

    ACF Pro: V 5.4.8
    Wordpress V 4.5.3

  • So after investigating a little, I was able to fix that.
    The issue was that I was using a new custom post type called ‘order’, which seems to conflict with ACF (no idea why).

    Changing my custom post type definition to something else ( ‘featuring_order’, in my case) solved the issue but it is really really strange…

  • I just had exactly the same issue. Thank god I saw this or I would of spent ages trying to figure it out.

    I had to rename my post type order to purchase_order and that fixed problem.

    So weird.

    I wasn’t using Custom Post Type UI plugin, I just had my post type hard coded with this…

    <?php
    class Types {
    
        /**
         * Types constructor.
         * @param null|int $id The Player ID to load
         */
        public function __construct ($id = null) {
    
            if(is_null($id)) {
    
                // on initial theme load, run various actions
                add_action('init', array ($this, 'action_init'));
    
            }
    
        }
    
        /**
         * Method to run on WordPress initialisation
         *
         * @uses init action
         * @see  https://codex.wordpress.org/Plugin_API/Action_Reference/init
         */
        public function action_init () {
    
            // register our post type
            $this->register_post_types();
    
        }
    
        /**
         * Returns an array of order labels available
         * to the labels post type
         *
         * @param null|string $key The specific label to load
         * @return array|string Array of labels or single
         * if key is defined
         */
        public static function order_labels ($key = null) {
    
            // create our array of labels
            $aLabels = array (
                'name'                  => 'Orders',
                'singular_name'         => 'Order',
                'add_new'               => 'Add order',
                'add_new_item'          => 'Add new order',
                'edit_item'             => 'Edit order',
                'new_item'              => 'Create order',
                'view_item'             => 'View order',
                'search_items'          => 'Search orders',
                'not_found'             => 'No orders found',
                'not_found_in_trash'    => 'No orders found in trash',
                'parent_item_colon'     => 'Parent order:',
                'all_items'             => 'All orders',
                'archives'              => 'Order archives',
                'insert_into_item'      => 'Insert within order',
                'uploaded_to_this_item' => 'Uploaded to order',
            );
    
            // check if we are returning a single label
            if(!is_null($key) && array_key_exists($key, $aLabels)) {
                return $aLabels[$key];
            }
    
            // by default return all labels
            return $aLabels;
    
        }
    
        /**
         * Registers post types
         * @return void
         */
        protected function register_post_types () {
    
            // register our field post type product
            register_post_type('order', array (
    
                // define our post type labels
                'label'   => self::order_labels('singular_name'),
                'labels'  => self::order_labels(),
    
                // make post type public queryable
                'public'              => true,
    
                // setup UI preferences
                'show_ui'             => true,
                'show_in_nav_menus'   => true,
                'show_in_menu'        => true,
                'show_in_admin_bar'   => false,
    
                // set our menu position and icon
                'menu_position'       => 50,
                'menu_icon'           => 'dashicons-list-view',
    
                // determine our capabilities & support
                'capability_type'     => 'post',
                'supports'            => array (
                    'title', 'author', 'editor'
                ),
    
                // archiving and linking
                'has_archive'         => false,
                'rewrite'             => array (
                    'slug'            => 'order',
                    'with_front'      => false,
                    'feeds'           => false,
                    'pages'           => false,
                    'ep_mask'         => EP_PERMALINK,
                ),
    
            ));
    
        }
    
    } new Types();
  • Hello from June 2021.

    This is still an issue. I cannot create a post type called “Order” because of this conflict.

    Normally, I would just rename the slug, but in my case it needs to be user-facing in the URL, and it’s important that the URL is clear and concise.

    @hube2 – can this be fixed on a future update?

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.