Support

Account

Home Forums Backend Issues (wp-admin) Field Groups not saving changes

Solved

Field Groups not saving changes

  • For some reason now I can’t change anything from my field groups. Any change I make on any field at Edit Field Group screen is ignored. Order, values, field types, names etc. Values from Location and Options are still changeable. Everything looks fine with the interface, but when I click Update, the changes made in any Field Group is ignored.
    I tried to reinstall the plugin and even WordPress, but that doesn’t fixed anything.
    What should I do?

    • Elliot

    • July 31, 2013 at 3:42 pm

    Hi @rdourado

    It is most likely that you have a conflict with another plugin which is preventing ACF from running the save function.

    Are you able to deactivate all plugins and swap to the default theme for testing?

  • Hi Elliot.

    I tested now with only ACF and addons activated and default theme… Nothing changed. The bug persists. :\

    • Elliot

    • August 1, 2013 at 12:49 pm

    Hi @rdourado

    Thanks for testing that. Are you able to post login details for me to take a look?

    You can mark the reply as private so only I will see the details

    Cheers
    E

  • I found the problem. It was a database problem. Some rows were duplicated because of a theme bug and the plugin was having problems finding the right row to apply the changes. So, not a ACF problem. Thank you for your help!

    • Awinad

    • September 29, 2013 at 8:37 pm

    Hi rdourado
    Can you give some more details on how you solved this?
    I see lots of fields in the post_meta table, but it all looks OK. There must be some issue with the backend when trying to update the value.

  • @rdourado we have exactly the same problem.
    any chances you can tell us what exactly caused the problem?

  • @despecial In my case, it was a theme related bug. I’ve just removed duplicated rows in database.
    But, it happened to me in another occasion and I solved it deleting the acf-json folder in my theme.

  • Thanks for your reply. I opened my own thread because our problem only happens on the production server and it seems to be related with timezones.

  • I’m having a very similar problem. When I try to add a new location rule, it won’t save.

    Could you tell me which database you edited to remove duplicate records?

  • I got here after googling “acf fields won’t save to group” because I was having an issue where I could save a parent field, but couldn’t save any child fields to that parent group. I’d hit save and they’d appear as siblings of the parent group rather than children (subfields). While troubleshooting, I reinstalled ACF and this caused an additional symptom where it appeared the entire field group was empty, though it wasn’t– above the existing fields, it read “No fields. Click the + Add Field button to create your first field.”

    I ruled out plugin conflicts (deactivated all other plugins) and then used a default theme which solved the issue, so I temporarily renamed the functions.php and that did the trick. After combing through some functions– it was crammed with different customizations that probably should’ve been plugins, because younger me didn’t know what I know now– I saw there was one that removed query strings from static resources which set off my spider sense. I removed it and that solved the problem. The offending code:

    `//Remove query strings from static resources

    function _remove_script_version( $src ){
    $parts = explode( ‘?ver’, $src );
    return $parts[0];
    }

    add_filter( ‘script_loader_src’, ‘_remove_script_version’, 15, 1 );
    add_filter( ‘style_loader_src’, ‘_remove_script_version’, 15, 1 );

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.