Home Forums Backend Issues (wp-admin) Field group not showing in backend since Woocommerce last update


Field group not showing in backend since Woocommerce last update

  • I use a field group to add informations to my WooCommerce products from the backend.
    The location rule is set to post taxonomy = a product_cat.
    It was working fine until I update to last WC version (8.2.1).
    Since this update, group field no longer appear on new product when clicking the checkbox of the corresponding product_cat neither is it listed in screen options.
    When editing an existing product, field group appear temporary but if I change any of its options based on taxonomy, it disappears.
    If I change the location rules of the field group to, for example, post type = product, it works normally, so it seems to be related to location rule.
    The issue only affect backend. On frontend everything is working fine.
    I set up a test site with only WooCommerce 8.2.1 and ACF 6.2.1 and the issue is there.

  • I see an error in JS console:

    [Error] TypeError: undefined is not an object (evaluating ‘e.getActiveMetaBoxLocations’)
    onRefreshPostScreen (acf-input.min.js:1:82303)
    o (acf.min.js:1:1423)
    doAction (acf.min.js:1:589)
    (función anónima) (acf.min.js:1:19488)
    renderPostScreen (acf-input.min.js:1:80681)
    success (acf-input.min.js:1:77961)
    c (load-scripts.php:7:25272)
    fireWith (load-scripts.php:7:26017)
    l (load-scripts.php:7:77733)
    (función anónima) (load-scripts.php:7:80206)

  • I had the same issue.

    I was able to fix it by rolling back to WooCommerce 8.1.1

  • This is what I did too for the moment.
    I also send a ticket reporting the issue. People at WP Engine kindly answer that they could replicate the issue and it’s under investigation. If they come with a fix, be sure I’ll share in this thread.

  • I’m going to make a guess here that people with this issue are using guberbug gutenberg. No one included this information, so I am assuming.

    This is a known issue using the wp block editor. This has been an issue with the new editor for quite some time. There are plenty of topics in this forum about this. I don’t see it being corrected any time soon.

    If you select the category and update the post and then reload the page the correct custom fields should appear.

  • As I said in my first post, changing any ACF options based on taxonomy, make the block to disappear.
    So yes, the trick of selecting the category and updating the product to make ACF block appear works but it doesn’t allow to do anything with it.
    Maybe the fact that my issue appears with a precise WC update and is solved rolling back to previous version plus the fact that it can be perfectly replicated will help developers to find something.

  • Just after writing the last reply, I have seen that ACF 6.2.2 is released. Just install it and as said in the changelog, the issue is solved.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.