Support

Account

Home Forums Bug Reports Field Group have limit fields?

Solving

Field Group have limit fields?

  • I created a layout module 7m (layouts). Each layout has about 15-20 fields (including eating and one repeater with fields). There comes a moment when I can not create more fields. And nothing else is stored. A begins to persist if you remove one field. Then another one I can keep.

    How can I fix this problem?

  • You need to alter your php ini setting max_input_vars. You’re reaching the maximum number of input fields allowed on your server.

  • I also want to clarify that the fields are not saved or added in the custom field, but not while retaining most of the post) (Field Group)

  • Notice: Undefined index: sub_fields in /home/surround/subdomains/staging/wp-content/plugins/acf-flexible-content/flexible-content.php on line 349

    Warning: Cannot modify header information – headers already sent by (output started at /home/surround/subdomains/staging/wp-content/plugins/acf-flexible-content/flexible-content.php:349) in /home/surround/subdomains/staging/wp-includes/pluggable.php on line 1121

  • This is a complete number of fields that can be added (if you add one more), nothing happens. New fields do not appear.

    http://awesomescreenshot.com/0f635h2s43

  • Your php setting for max_input_vars is 3000

    Look at the field group you’re creating. Each field you’re creating has many inputs there may even be a bunch of hidden inputs. If you add them all up they are most probably near your 3000 limit.

    When you submit the page to save your fields, if there are more than 3000, php simply throws away the excess, so they are not submitted to the script that needs to save your field group.

    Does your host allow you to increase that setting? I would suggest upping it to 5000 see what happens. If your host does not allow you do change that php setting then you’ll need to figure out a different way to accomplish what you want to do using less fields.

  • You understand me correctly, I can not add more fields on the page is
    http://awesomescreenshot.com/0f635h2s43

    In the post, normally stored in all fields.

    max_input_vars 6000 Nothing has changed.
    http://awesomescreenshot.com/07635hbsb8

  • 44 filds (all including repeater ) in 7 Layout
    I really need to solve this problem. I need at least another 10 fields.

  • Then you have me stumped. The only time I’ve ever had a problem creating more fields is when I exceed max_input_vars.

    There are a couple other php settings you can try increasing:
    post_max_size
    max_input_nesting_level

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.