Support

Account

Home Forums Add-ons Flexible Content Field Error with Flexible Content Fields add on

Solved

Error with Flexible Content Fields add on

  • Hi there, I’ve created quite a large flexible content field, with multiple layouts and nested repeaters and recently I’ve come into an issue with the conditional logic. I’ve set the conditional logic as follows on this flexible content field:
    Show if post type equals post
    OR
    Show if post type equals page
    OR
    Show if post type equals knowledge-centre

    The flexible content field is showing on posts or pages, but not on knowledge-centre posts.

    When I edit a post/page/knowledge-centre, I get the following error at the top of the page:
    Notice: Undefined index: operator in C:\xampp\htdocs\xxxxxxxx\wp-content\plugins\advanced-custom-fields\core\controllers\location.php on line 244

    Notice: Undefined index: operator in C:\xampp\htdocs\xxxxxxxx\wp-content\plugins\advanced-custom-fields\core\controllers\location.php on line 248

    Does anyone know what could be causing this issue?

  • Anyone? This is kind of urgent, I’ve tried deleting the field and recreating the flexible content layout again, still the issue persists.

    Would appreciate a reply.

    Thanks

  • Hi xanthonius,

    Might be too late, but I just had a similar issue and found this thread. For me it was caused by max_input_vars being set too low in php.ini.

    This setting controls how many variables will be accepted by PHP at once. Building a large ACF field group in the admin can require sending hundreds or thousands of variables to the server on save, so if max_input_vars is set too low and the field group you’re building is too big, your data gets truncated when you save it – in this case, probably in the middle of a conditional logic section.

    PHP documentation for the setting is at http://php.net/manual/en/info.configuration.php#ini.max-input-vars, but if you google ACF max_input_vars you’ll likely find more relevant help.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.