Support

Account

Home Forums ACF PRO Elliot Please HELP I'm at Wits End

Solved

Elliot Please HELP I'm at Wits End

  • Okay so I spent time with a forum expert and he is at a loss.

    I submitted a ticket days ago with no answer.

    My problem.
    I have a clean WordPress install and things work for a while then all the sudden I can no longer save any data.

    I have disabled all plugins
    Switched to default WordPress 2015 theme
    Enabled Debug
    Checked error logs
    Contacted hosting company (hostgator) to check for mod sec issues.
    I have deleted and recreated all the fields
    I’ve tried changing field names
    and still I’m stuck

    I’ve even tried wiping everything out and reinstalling WordPress and ACF and the same thing happens all over again.

    Someone, Anyone PLEASE PLEASE HELP ME!!!

    I’m running the latest version of ACF 5 using repeater fields and WordPress

  • Jeffrey, I’ve looked into your problem a little further.

    The cause of your woes is the validation field plugin. This plugin uses non standard field keys.

    If you show the field keys of all of your fields you will see the difference. all of the ACF fields keys start with field_ and all of the fields that you created using the validation field add on to not use this naming convention.

    The data is being saved, but ACF does not know how to find that data because the field keys do not conform to what ACF is looking for.

    You need to talk to the developer of that plugin.

  • Are you sure? Because like I said I disabled all the plugins and recreated the fields and it still wouldn’t work

  • I’ve deleted the validation plugin, went into the database and deleted everything I could find related to the ACF Group.

    Then recreated it and again, the problem is still there. I also went into the database after recreating the group and adding an entry and the entry does not show in the database.

  • Yes, I disabled the plugin after importing your field group and the field keys were still wrong. If I delete the field that was created while that plugin was active and then recreate it as a normal text field everything works.

    You can’t continue to use that field group. Editing a field will not correct the field keys. The field needs to be completely deleted and recreated.

    You may have other issues going on as well, but I saw the same thing you reported, fields not saving. I deactivated the plugin, created new fields and the new fields saved as espected.

  • Attach the JSON export of your new field group to a reply.

  • okay , it’s just one field to test at this point.
    i also put a ticket into hostgator to check for database permissions as this is such a weird issue.

  • I just setup a local copy of wordpress on my NAS

    installed acf and imported the json. I installed absolutely noting else and change no other settings and I have the exact same results.

    I deleted the import and set it up again and it works. so it is something with my server with hostgator I’m guessing

  • So, looking that the json file you attached

    
        "fields": [
                {
                    "key": "staff-members",
                    ..............
    

    the we look further down at

    
            "sub_fields": [
                        {
                            "key": "name",
                            ..............
    

    That is the problem. The plugin that you had installed, the validation field plugin, changed the key value. It should look something like field_0112ab5e75678. This is the reason that data is not saving properly and being retrieved properly by ACF5. This kind of field key renaming used to work and may still work in ACF4 but won’t work in ACF5.

    This is what a normal field export would look like:

    
        "fields":[
          {
            "key":"field_55946dcc88ab8",
            ..............
    

    You need to delete the entire works and recreate it without that plugin being active and you need to contact the developer of that plugin about making it compatible with ACF5, or at least remove the “or greater” part of where it says “Requires Advanced Custom Fields version 4.0 or greater.”

    EDIT:I have been looking for information on when this changed or if there is a setting that will make these fields work, but I cannot find anything. I do remember that in the past at some point I had a serious issue with one of my plugins. It stopped working completely. I was also using custom key values that did not conform to the ‘field_’ pattern. I corrected the problem by making sure that my keys always conformed to this pattern and since then I have not tried to use custom key values.

  • Here is a recent post by Elliot on the subject of field keys

    http://support.advancedcustomfields.com/forums/topic/creating-theme-fields-generating-a-key/

  • John!!!!

    Thank you I owe you a great debt. I did as you suggested, I removed WordPress completely and reinstalled without that one plugin and things seems to be working!

    I honestly cannot believe that was causing issues even after I had disabled it or deleted it. Sigh…

    Again thank you!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.