Support

Account

Home Forums Bug Reports Duplicate entries in Flexible content field?

Unread

Duplicate entries in Flexible content field?

  • I have a website created back in 2017 using ACF pro, and this site has since been worked on a lot by the client since then, a lot of content has been created.

    However, some posts now can not update their custom fields data. When we insert data and click Update some of the updated fields just gets ignored, and are empty again after the update.

    Clicking Preview “works” in so far as the data is actually visible in the preview, and you can find the data in the DB for the temporarily created post, but doing an actual Update does not work.

    Looking at the data in the database for posts which have this issue I find a lot of children of the flexible content module which seem to conflict with each other. For example, modules_all_9_downloads_0_file and modules_all_9_column_items_3_link_button both exists, suggesting that slot 9 (or 10 if it is zero based index?) for the flexible content has both a Downloads module and a Column Items module? Or can this be due to some other reason? I tried creating a completely new post, and moving some flexible content items around up and down, and when looking a the postsmeta table for that post there was never that kind of duplication going on, also the data saved correctly.

    Has anyone else experienced this?

    This is a major issue for my client who can no longer update their website basically, sometimes 90% of a page can just disappear when updating some unrelated content.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.