Support

Account

Home Forums ACF PRO Disabling repeater collapsed fields leaves it broken

Solved

Disabling repeater collapsed fields leaves it broken

  • In my repeater field’s settings, under “Select a sub field to show when row is collapsed”, I chose one of my fields. Since I’m using a table layout, it ended up making the layout wonky, so I wanted to disable it. I set the Collapsed setting back to “- Select -” on my repeater which disabled it, but now all of my fields are hidden!

    Screenshot: http://awa.lt/11hmt

    Any idea what’s up with this?

  • Hi @adamwalter

    It seems ACF doesn’t check if the collapsed setting is set or not. I’ll pass this issue to the plugin author and hope he can fix it soon. For now, you can check the “wp_usermeta” table and delete the entries with “acf_user_settings” as the meta_key for your user. Please backup your database first before editing anything in it.

    Thanks!

  • Thank you! I had to change that meta value to a:0:{}. Emptying it completely resulted in all my fields disappearing!

  • Hi @adamwalter

    Thanks for the bug report.

    What v of ACF PRO are you using?
    I can’t replicate this issue on my end.

    Using the collapse setting in a table layout should work perfectly, and removing the ‘collapsed’ setting should have no issues either.

    Perhaps you could provide some login info for us to test? Maybe JS / PHP error is occurring on your edit page and causing the issue?

  • @elliot: I am using the latest ACF Pro. I can say that I’d never seen that happen before, so perhaps it was a fluke. The site is an active development project, so any number of things might have borked it. If I ever see it again, I’ll try to gather more data. Thanks!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.